summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz Tiram <oz.tiram@gmail.com>2024-09-26 10:39:07 +0200
committerMatt Jolly <kangie@gentoo.org>2024-10-03 11:12:17 +1000
commiteb3aa23351669a9343a448ed3f99866339cdbdf2 (patch)
tree868bab0f36623d357c0fee2485eed8ea009ea64a /x11-misc
parentnet-libs/nghttp3: keyword 1.5.0 for ~mips (diff)
downloadgentoo-eb3aa23351669a9343a448ed3f99866339cdbdf2.tar.gz
gentoo-eb3aa23351669a9343a448ed3f99866339cdbdf2.tar.bz2
gentoo-eb3aa23351669a9343a448ed3f99866339cdbdf2.zip
x11-misc/mate-notification-daemon: add 1.28.1
Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/mate-notification-daemon/Manifest1
-rw-r--r--x11-misc/mate-notification-daemon/mate-notification-daemon-1.28.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-misc/mate-notification-daemon/Manifest b/x11-misc/mate-notification-daemon/Manifest
index ca8036444c73..f78137fb22aa 100644
--- a/x11-misc/mate-notification-daemon/Manifest
+++ b/x11-misc/mate-notification-daemon/Manifest
@@ -1 +1,2 @@
DIST mate-notification-daemon-1.28.0.tar.xz 433572 BLAKE2B 89c386fb7707b87de61e5346ab018227864427d590e2908f0c85b8697d2d19d3528870f701adfa8f9657ea395718724d6398baf325d0b1d68284eb855f16df3f SHA512 dba0989945b81ff0fed5e77ac8ef7c96bf52ee854c9dc0f46549697e0d0537a8ff4a9491839076768443cc62140d1dfbf911aee489ab568c2975b67c52c78d2e
+DIST mate-notification-daemon-1.28.1.tar.xz 433384 BLAKE2B 688ef695520eba6e7964acff31303978c99dbfc724d6931ad341c2d3608fccc95bf37893b0445897e67572e52ce2b9372b09c98ba6b1cb3d3bf3bd4648269288 SHA512 72b6b4579d0571638708c5b326cad1b0de8aa2e65b775bf687bf944bca8db74177f018fc105465877f18eeb8ee297350ce8aba74a206a24f3f6c2e42af97ace5
diff --git a/x11-misc/mate-notification-daemon/mate-notification-daemon-1.28.1.ebuild b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.28.1.ebuild
new file mode 100644
index 000000000000..a1e84c301f57
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.28.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE Notification daemon"
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+
+IUSE="nls X wayland"
+REQUIRED_USE="|| ( X wayland )"
+
+COMMON_DEPEND="dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libxml2-2.9.0
+ >=sys-apps/dbus-1
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/libnotify-0.7
+ >=x11-libs/gtk+-3.22:3
+ >=media-libs/libcanberra-0.4:0[gtk3]
+ X? (
+ x11-libs/libX11
+ >=x11-libs/libwnck-3:3
+ )
+ wayland? ( gui-libs/gtk-layer-shell )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ !x11-misc/notify-osd
+ !x11-misc/qtnotifydaemon
+ !x11-misc/notification-daemon
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ mate-base/mate-panel
+"
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable nls) \
+ $(use_enable X x11) \
+ $(use_enable wayland)
+}
+
+src_install() {
+ mate_src_install
+
+ insinto /usr/share/dbus-1/services
+ doins "${FILESDIR}/org.freedesktop.Notifications.service"
+}