summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-26 00:11:21 +0100
committerSam James <sam@gentoo.org>2021-07-26 00:23:35 +0100
commit6118c0e2e25e655cdf9ae2608277822ea706ccb3 (patch)
tree3d85170dfec852eb533136c3081e7c88638fedf4 /x11-misc
parentx11-misc/slim: EAPI 7, cmake-utils--, fix build with GCC 11 (diff)
downloadgentoo-6118c0e2e25e655cdf9ae2608277822ea706ccb3.tar.gz
gentoo-6118c0e2e25e655cdf9ae2608277822ea706ccb3.tar.bz2
gentoo-6118c0e2e25e655cdf9ae2608277822ea706ccb3.zip
x11-misc/slim: drop obsolete live ebuild
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/slim/slim-1.3.6-r5.ebuild9
-rw-r--r--x11-misc/slim/slim-9999.ebuild131
2 files changed, 2 insertions, 138 deletions
diff --git a/x11-misc/slim/slim-1.3.6-r5.ebuild b/x11-misc/slim/slim-1.3.6-r5.ebuild
index 66c1f3e89e61..880a442d8477 100644
--- a/x11-misc/slim/slim-1.3.6-r5.ebuild
+++ b/x11-misc/slim/slim-1.3.6-r5.ebuild
@@ -6,13 +6,8 @@ EAPI=7
inherit cmake pam systemd
DESCRIPTION="Simple Login Manager"
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/axs-gentoo/slim-git.git"
- inherit git-r3
-else
- SRC_URI="mirror://sourceforge/project/${PN}.berlios/${P}.tar.gz"
- KEYWORDS="amd64 arm ~arm64 ~mips ppc ppc64 sparc x86"
-fi
+SRC_URI="mirror://sourceforge/project/${PN}.berlios/${P}.tar.gz"
+KEYWORDS="amd64 arm ~arm64 ~mips ppc ppc64 sparc x86"
LICENSE="GPL-2"
SLOT="0"
diff --git a/x11-misc/slim/slim-9999.ebuild b/x11-misc/slim/slim-9999.ebuild
deleted file mode 100644
index cfaf87f96c02..000000000000
--- a/x11-misc/slim/slim-9999.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake pam systemd
-
-DESCRIPTION="Simple Login Manager"
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/axs-gentoo/slim-git.git"
- inherit git-r3
-else
- SRC_URI="mirror://sourceforge/project/${PN}.berlios/${P}.tar.gz"
- KEYWORDS="amd64 arm ~arm64 ~mips ppc ppc64 sparc x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="branding pam"
-
-RDEPEND="x11-libs/libXmu
- x11-libs/libX11
- x11-libs/libXpm
- x11-libs/libXft
- x11-libs/libXrandr
- media-libs/libpng:0=
- virtual/jpeg:=
- x11-apps/sessreg
- pam? ( sys-libs/pam
- !x11-misc/slimlock )"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
-BDEPEND="virtual/pkgconfig"
-PDEPEND="branding? ( >=x11-themes/slim-themes-1.2.3a-r3 )"
-
-PATCHES=(
- # Our Gentoo-specific config changes
- "${FILESDIR}"/${P}-config.diff
-)
-
-src_prepare() {
- cmake_src_prepare
-
- if use elibc_FreeBSD; then
- sed -i -e 's/"-DHAVE_SHADOW"/"-DNEEDS_BASENAME"/' CMakeLists.txt \
- || die
- fi
-
- if use branding; then
- sed -i -e '/current_theme/s/default/slim-gentoo-simple/' slim.conf \
- || die
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_PAM=$(usex pam)
- -DUSE_CONSOLEKIT=OFF
- )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- if use pam ; then
- pamd_mimic system-local-login slim auth account session
- pamd_mimic system-local-login slimlock auth
- fi
-
- systemd_dounit build_files/slim.service
-
- insinto /usr/share/slim
- newins "${FILESDIR}/Xsession-r3" Xsession
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}/slim.logrotate" slim
-
- dodoc xinitrc.sample README THEMES
-}
-
-pkg_postinst() {
- # massage ${REPLACING_VERSIONS} to come up with whether or not it's a new install
- # or if it's older than 1.3.2-r7
- # Note - there should only ever be zero or one version as this package isn't slotted,
- # so the logic doesn't worry about what happens if there's two, due to the case where
- # a previous emerge attempt failed in the middle of qmerge.
- local rv=none
- for rv in ${REPLACING_VERSIONS} ; do
- if ver_test "1.3.2-r7" -le "${rv}" ; then
- rv=newer
- break;
- fi
-
- if ver_test "1.0" -le "${rv}" ; then
- rv=older
- break;
- fi
- done
-
- if [[ ${rv} == none ]]; then
- elog
- elog "The configuration file is located at /etc/slim.conf."
- elog
- elog "If you wish ${PN} to start automatically, set DISPLAYMANAGER=\"${PN}\" "
- elog "in /etc/conf.d/xdm and run \"rc-update add xdm default\"."
- fi
- if [[ ${rv} != newer ]]; then
- elog
- elog "By default, ${PN} is set up to do proper X session selection, including ~/.xsession"
- elog "support, as well as selection between sessions available in"
- elog "/etc/X11/Sessions/ at login by pressing [F1]."
- elog
- elog "The XSESSION environment variable is still supported as a default"
- elog "if no session has been specified by the user."
- elog
- elog "If you want to use .xinitrc in the user's home directory for session"
- elog "management instead, see README and xinitrc.sample in"
- elog "/usr/share/doc/${PF} and change your login_cmd in /etc/slim.conf"
- elog "accordingly."
- elog
- fi
-
- if ! use pam; then
- elog "You have merged ${PN} without USE=\"pam\", this will cause ${PN} to fall back to"
- elog "the console when restarting your window manager. If this is not desired, then"
- elog "please remerge ${PN} with USE=\"pam\""
- elog
- fi
-}