summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2021-10-12 10:18:19 +0200
committerFlorian Schmaus <flow@gentoo.org>2021-10-12 10:19:16 +0200
commit513d62fb5f7d37b27f0d109e6a21f55378a94473 (patch)
tree5245a25b12ff2b3c6e8da905a42579380f8ae163 /x11-misc
parentsci-mathematics/gmp-ecm: remove old "unused" gmp-ecm-7.0.4-r2.ebuild. (diff)
downloadgentoo-513d62fb5f7d37b27f0d109e6a21f55378a94473.tar.gz
gentoo-513d62fb5f7d37b27f0d109e6a21f55378a94473.tar.bz2
gentoo-513d62fb5f7d37b27f0d109e6a21f55378a94473.zip
x11-misc/rofi: sync live ebuild with latest non-live ebuild
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rofi/rofi-99999.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/x11-misc/rofi/rofi-99999.ebuild b/x11-misc/rofi/rofi-99999.ebuild
index 5612e93f9552..080d70670508 100644
--- a/x11-misc/rofi/rofi-99999.ebuild
+++ b/x11-misc/rofi/rofi-99999.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit autotools git-r3 toolchain-funcs
DESCRIPTION="A window switcher, run dialog and dmenu replacement"
@@ -11,13 +12,15 @@ EGIT_REPO_URI="https://github.com/davatorium/rofi"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE="test windowmode"
+IUSE="+drun test +windowmode"
RESTRICT="!test? ( test )"
+BDEPEND="virtual/pkgconfig"
RDEPEND="
dev-libs/glib:2
gnome-base/librsvg:2
media-libs/freetype
+ virtual/jpeg
x11-libs/cairo[X,xcb(+)]
x11-libs/libXft
x11-libs/libXinerama
@@ -32,25 +35,22 @@ RDEPEND="
"
DEPEND="
${RDEPEND}
- virtual/pkgconfig
x11-base/xorg-proto
test? ( >=dev-libs/check-0.11 )
"
-PATCHES=(
- "${FILESDIR}"/${PN}-0.15.12-Werror.patch
- "${FILESDIR}"/${PN}-1.5.0-gtk-settings-test.patch
-)
src_prepare() {
default
-
eautoreconf
}
src_configure() {
tc-export CC
- econf \
- $(use_enable test check) \
+ local myeconfargs=(
+ $(use_enable drun)
+ $(use_enable test check)
$(use_enable windowmode)
+ )
+ econf "${myeconfargs[@]}"
}