summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kszczot <filip@kszczot.pl>2022-03-31 15:57:53 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-04-08 15:16:55 +0300
commite692b3777bcebd5adf29681376d60cacc91969a1 (patch)
tree82aaac2b116317aff0b35ae8949e218e2339cafb /x11-misc/trayer-srg
parentsys-cluster/charliecloud: quote ${PYTHON}, sync live ebuild (diff)
downloadgentoo-e692b3777bcebd5adf29681376d60cacc91969a1.tar.gz
gentoo-e692b3777bcebd5adf29681376d60cacc91969a1.tar.bz2
gentoo-e692b3777bcebd5adf29681376d60cacc91969a1.zip
x11-misc/trayer-srg: ebuild enhancements
- add BDEPEND, - EAPI-8, - modify src_compile to not build a development version. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Filip Kszczot <filip@kszczot.pl> Closes: https://github.com/gentoo/gentoo/pull/24830 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc/trayer-srg')
-rw-r--r--x11-misc/trayer-srg/trayer-srg-1.1.8-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/trayer-srg/trayer-srg-1.1.8-r1.ebuild b/x11-misc/trayer-srg/trayer-srg-1.1.8-r1.ebuild
new file mode 100644
index 000000000000..93680dad5544
--- /dev/null
+++ b/x11-misc/trayer-srg/trayer-srg-1.1.8-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="trayer fork with multi monitor support and cleaned up codebase"
+HOMEPAGE="https://github.com/sargon/trayer-srg"
+SRC_URI="https://github.com/sargon/${PN}/archive/${P/-srg/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${PN}-trayer-${PV}
+
+src_configure() {
+ ./configure --prefix="${EPREFIX}" || die
+}
+
+src_compile() {
+ emake TARGET=${PN} CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ einstalldocs
+}