summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-03-20 22:02:05 +0100
committerJeroen Roovers <jer@gentoo.org>2019-03-20 22:03:20 +0100
commitb673b69a07dfaec985c3666e07abfe9ff69709a9 (patch)
treebca5ba957c0f1bc9e148aa4c155a89284ee0d1bd /x11-misc/simpleswitcher
parentdev-lang/php: amd64 stable wrt bug #681074 (diff)
downloadgentoo-b673b69a07dfaec985c3666e07abfe9ff69709a9.tar.gz
gentoo-b673b69a07dfaec985c3666e07abfe9ff69709a9.tar.bz2
gentoo-b673b69a07dfaec985c3666e07abfe9ff69709a9.zip
x11-misc/simpleswitcher: Add snapshot, move live ebuild
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/simpleswitcher')
-rw-r--r--x11-misc/simpleswitcher/Manifest1
-rw-r--r--x11-misc/simpleswitcher/simpleswitcher-20140219.ebuild36
-rw-r--r--x11-misc/simpleswitcher/simpleswitcher-99999999.ebuild (renamed from x11-misc/simpleswitcher/simpleswitcher-9999.ebuild)20
3 files changed, 48 insertions, 9 deletions
diff --git a/x11-misc/simpleswitcher/Manifest b/x11-misc/simpleswitcher/Manifest
new file mode 100644
index 000000000000..a1629923c59d
--- /dev/null
+++ b/x11-misc/simpleswitcher/Manifest
@@ -0,0 +1 @@
+DIST simpleswitcher-20140219-cbc89a71a61fd2d164c3fdc3ef4d3fa809c1741a.tar.gz 16370 BLAKE2B 5bc23dcb26a99857c943b52b857f227043f3062337815f9d9f7feef05120abcdec31c3d756433e763b984cc8df506c9667954de200f19edff72a7a9efab9dbde SHA512 1c17e1858855d587a85a2ba2c0000ddc3e6da0e8bfdb6703de04a7bceaa575d2db0b8a032f3833c1f08c0ce413eaa1908fa62c6b6c98dba367668a7bceec467c
diff --git a/x11-misc/simpleswitcher/simpleswitcher-20140219.ebuild b/x11-misc/simpleswitcher/simpleswitcher-20140219.ebuild
new file mode 100644
index 000000000000..6088df3f2461
--- /dev/null
+++ b/x11-misc/simpleswitcher/simpleswitcher-20140219.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+SSHASH="cbc89a71a61fd2d164c3fdc3ef4d3fa809c1741a"
+DESCRIPTION="lightweight EWMH window switcher with features and looks of dmenu"
+HOMEPAGE="https://github.com/seanpringle/simpleswitcher"
+SRC_URI="${HOMEPAGE}/archive/${SSHASH}.tar.gz -> ${P}-${SSHASH}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXres
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+S=${WORKDIR}/${PN}-${SSHASH}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}
diff --git a/x11-misc/simpleswitcher/simpleswitcher-9999.ebuild b/x11-misc/simpleswitcher/simpleswitcher-99999999.ebuild
index c1f66e461b21..3430c6607dc1 100644
--- a/x11-misc/simpleswitcher/simpleswitcher-9999.ebuild
+++ b/x11-misc/simpleswitcher/simpleswitcher-99999999.ebuild
@@ -1,25 +1,27 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
+EAPI=7
inherit git-r3 toolchain-funcs
DESCRIPTION="lightweight EWMH window switcher with features and looks of dmenu"
HOMEPAGE="https://github.com/seanpringle/simpleswitcher"
-EGIT_REPO_URI="https://github.com/seanpringle/simpleswitcher"
+EGIT_REPO_URI="${HOMEPAGE}"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE=""
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXft
x11-libs/libXinerama
- x11-libs/libXres"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ x11-libs/libXres
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
src_compile() {
tc-export CC