summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-07 18:39:42 +0200
committerMarek Szuba <marecki@gentoo.org>2021-05-07 18:50:29 +0200
commit1a5aaf968f9e2759c1906db019d5dba68e7393a0 (patch)
tree8b99b8b489f0c82ba0850b4145aabc5d477b12fe /x11-misc/read-edid
parentgames-arcade/batrachians: Remove old 0.1.6-r1 (diff)
downloadgentoo-1a5aaf968f9e2759c1906db019d5dba68e7393a0.tar.gz
gentoo-1a5aaf968f9e2759c1906db019d5dba68e7393a0.tar.bz2
gentoo-1a5aaf968f9e2759c1906db019d5dba68e7393a0.zip
x11-misc/read-edid: make get-edid VBE mode optional
Not compatible with some previously supported arches, moreover according to upstream the new, i2c-based interface "tends to work much better and in many more cases than the old interface". While at it, switch to EAPI 7 and cmake.eclass. Bug: https://bugs.gentoo.org/764026 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'x11-misc/read-edid')
-rw-r--r--x11-misc/read-edid/metadata.xml4
-rw-r--r--x11-misc/read-edid/read-edid-3.0.2-r1.ebuild32
2 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/read-edid/metadata.xml b/x11-misc/read-edid/metadata.xml
index 3e5026ee3754..37810b80659d 100644
--- a/x11-misc/read-edid/metadata.xml
+++ b/x11-misc/read-edid/metadata.xml
@@ -5,4 +5,8 @@
<email>marecki@gentoo.org</email>
<name>Marek Szuba</name>
</maintainer>
+ <use>
+ <flag name="vbe-mode">Build get-edid with support for legacy, VBE-based interface.
+ Requires <pkg>dev-libs/libx86</pkg>.</flag>
+ </use>
</pkgmetadata>
diff --git a/x11-misc/read-edid/read-edid-3.0.2-r1.ebuild b/x11-misc/read-edid/read-edid-3.0.2-r1.ebuild
new file mode 100644
index 000000000000..3b48fa3a376b
--- /dev/null
+++ b/x11-misc/read-edid/read-edid-3.0.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Program that can get information from a PnP monitor"
+HOMEPAGE="http://www.polypux.org/projects/read-edid/"
+SRC_URI="http://www.polypux.org/projects/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vbe-mode"
+
+DEPEND="vbe-mode? ( >=dev-libs/libx86-1.1 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's|COPYING||g;s|share/doc/read-edid|share/doc/'"${PF}"'|g' \
+ CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ append-cflags -fcommon
+ local mycmakeargs=(
+ -DCLASSICBUILD=$(usex vbe-mode)
+ )
+ cmake_src_configure
+}