summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-21 11:10:13 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-21 11:48:10 -0400
commit2789250e7e776e19599bab2da0fd20b4e8ddbe2d (patch)
tree8e5e0c60a9d86e1716562043a08a4f561cbd676a /x11-misc/ktsuss/ktsuss-2.1-r1.ebuild
parentnet-print/pnm2ppa: fix build w/ upcoming clang16 (diff)
downloadgentoo-2789250e7e776e19599bab2da0fd20b4e8ddbe2d.tar.gz
gentoo-2789250e7e776e19599bab2da0fd20b4e8ddbe2d.tar.bz2
gentoo-2789250e7e776e19599bab2da0fd20b4e8ddbe2d.zip
x11-misc/ktsuss: EAPI6->8, fix deps and build w/ clang16
bug #781185 could have two causes, either no su(1) or no which(1) given neither are guaranteed. Closes: https://bugs.gentoo.org/781185 Closes: https://bugs.gentoo.org/874540 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-misc/ktsuss/ktsuss-2.1-r1.ebuild')
-rw-r--r--x11-misc/ktsuss/ktsuss-2.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/ktsuss/ktsuss-2.1-r1.ebuild b/x11-misc/ktsuss/ktsuss-2.1-r1.ebuild
new file mode 100644
index 000000000000..87718a586671
--- /dev/null
+++ b/x11-misc/ktsuss/ktsuss-2.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Graphical version of su written in C and GTK+ 2"
+HOMEPAGE="https://github.com/nomius/ktsuss/"
+SRC_URI="https://github.com/nomius/ktsuss/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 x86"
+IUSE="sudo"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ dev-libs/glib:2
+ sudo? ( app-admin/sudo )
+ !sudo? (
+ || (
+ sys-apps/util-linux[su]
+ sys-apps/shadow[su]
+ )
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( Changelog CREDITS README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+ "${FILESDIR}"/${P}-no-which.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable sudo)
+}