summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/cbatticon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/cbatticon')
-rw-r--r--x11-misc/cbatticon/Manifest3
-rw-r--r--x11-misc/cbatticon/cbatticon-1.3.2.ebuild30
-rw-r--r--x11-misc/cbatticon/cbatticon-1.4.1.ebuild39
-rw-r--r--x11-misc/cbatticon/cbatticon-1.4.2.ebuild39
-rw-r--r--x11-misc/cbatticon/metadata.xml8
5 files changed, 119 insertions, 0 deletions
diff --git a/x11-misc/cbatticon/Manifest b/x11-misc/cbatticon/Manifest
new file mode 100644
index 000000000000..5ee155d7c475
--- /dev/null
+++ b/x11-misc/cbatticon/Manifest
@@ -0,0 +1,3 @@
+DIST cbatticon-1.3.2.tar.gz 12749 SHA256 40f5b80e9a405ce79ecca74bcd72778372729b2add63a9c4e3386908cfb8ad4c SHA512 492b0e9e16b7a14a8bf184d213af7c7366a2cd8bfe9fe91e935e95a72e8f5213029d8b32512961f142da9db3832dd5fa98f291223b0d473a133132614ed926aa WHIRLPOOL 78cc260cc9060931cea9b9fa87e0be81b33f74641cd09a4592911612ae78e3c0ee80c4e2f045c186f030f389946264e1468451068c4fe319d9247d30f227d9b5
+DIST cbatticon-1.4.1.tar.gz 14334 SHA256 ba6ef1b588530d31af41173a188d7333d68c83ea6e579e6f93e8acde854c3a26 SHA512 5b133705b7cbc6b778f677117ae3f936511a8d35eafa00de1a2fdb7901ef8b98c76b0fc5e50fb21e3592c264ce4490a35806363d4446eca6384b48572a848577 WHIRLPOOL c91116fd1962e07227dd784e3c259cdfda8c46275f19994df488130bd3b4595808b79e8440c3710d96156b960bf14dd1fc876a390d762adb9e4289a4289a9705
+DIST cbatticon-1.4.2.tar.gz 14449 SHA256 987d979c426c12d7ef6ce7856a7c0d0d0a70720cafcada9ba6a4800d048ef502 SHA512 53d0ff654758a7c40f32a86a4364ff2b57f23bec9a10d3c9964eb7afb59bfd2d8ee21c5ece9d6bb4b99c54dbfb1f6b8ab7e36e93c246d0fef4e300416b1159fe WHIRLPOOL 4db6b81e668504001b39a53ca19920c57f6d868b236805b5c3a46a769b197053507681a6ebad4d70641a90919852144176cece64e99905eb9bb9f74dc430323d
diff --git a/x11-misc/cbatticon/cbatticon-1.3.2.ebuild b/x11-misc/cbatticon/cbatticon-1.3.2.ebuild
new file mode 100644
index 000000000000..c8c2adcd94b1
--- /dev/null
+++ b/x11-misc/cbatticon/cbatticon-1.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="A GTK+ battery icon which uses libudev to be lightweight and fast"
+HOMEPAGE="https://github.com/ColinJones/cbatticon"
+SRC_URI="https://github.com/ColinJones/cbatticon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libnotify"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile() {
+ tc-export CC
+ emake V=1 VERSION="${PF}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" V=1 VERSION="${PF}" install
+}
diff --git a/x11-misc/cbatticon/cbatticon-1.4.1.ebuild b/x11-misc/cbatticon/cbatticon-1.4.1.ebuild
new file mode 100644
index 000000000000..01840f093d8e
--- /dev/null
+++ b/x11-misc/cbatticon/cbatticon-1.4.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="A lightweight and fast battery icon that sits in your system tray"
+HOMEPAGE="https://github.com/ColinJones/cbatticon"
+SRC_URI="https://github.com/ColinJones/cbatticon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_compile() {
+ tc-export CC
+ emake \
+ $(usex libnotify WITH_NOTIFY=1 WITH_NOTIFY=0) \
+ V=1 \
+ VERSION="${PF}" \
+ WITH_GTK3=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" V=1 VERSION="${PF}" install
+}
diff --git a/x11-misc/cbatticon/cbatticon-1.4.2.ebuild b/x11-misc/cbatticon/cbatticon-1.4.2.ebuild
new file mode 100644
index 000000000000..01840f093d8e
--- /dev/null
+++ b/x11-misc/cbatticon/cbatticon-1.4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="A lightweight and fast battery icon that sits in your system tray"
+HOMEPAGE="https://github.com/ColinJones/cbatticon"
+SRC_URI="https://github.com/ColinJones/cbatticon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_compile() {
+ tc-export CC
+ emake \
+ $(usex libnotify WITH_NOTIFY=1 WITH_NOTIFY=0) \
+ V=1 \
+ VERSION="${PF}" \
+ WITH_GTK3=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" V=1 VERSION="${PF}" install
+}
diff --git a/x11-misc/cbatticon/metadata.xml b/x11-misc/cbatticon/metadata.xml
new file mode 100644
index 000000000000..419ec4f290b0
--- /dev/null
+++ b/x11-misc/cbatticon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <upstream>
+ <remote-id type="github">ColinJones/cbatticon</remote-id>
+ </upstream>
+</pkgmetadata>