summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-11-02 13:39:52 -0400
committerMatt Turner <mattst88@gentoo.org>2022-11-02 13:43:06 -0400
commit3aea8f122fa335f3545b9b218136a6ccb3e7e57c (patch)
treec90d5da1c5e860d76e52087d46aa672ace9e6698 /x11-libs/pixman
parentsec-policy: drop SELinux policies 2.20221101-r1 (diff)
downloadgentoo-3aea8f122fa335f3545b9b218136a6ccb3e7e57c.tar.gz
gentoo-3aea8f122fa335f3545b9b218136a6ccb3e7e57c.tar.bz2
gentoo-3aea8f122fa335f3545b9b218136a6ccb3e7e57c.zip
x11-libs/pixman: Version bump to 0.42.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/pixman')
-rw-r--r--x11-libs/pixman/Manifest1
-rw-r--r--x11-libs/pixman/pixman-0.42.2.ebuild64
-rw-r--r--x11-libs/pixman/pixman-9999.ebuild2
3 files changed, 67 insertions, 0 deletions
diff --git a/x11-libs/pixman/Manifest b/x11-libs/pixman/Manifest
index e31b21c01b32..5e301e406d24 100644
--- a/x11-libs/pixman/Manifest
+++ b/x11-libs/pixman/Manifest
@@ -1 +1,2 @@
DIST pixman-0.40.0.tar.xz 634752 BLAKE2B 29b71f5eb6c3df0318c7a6153c6abbce29748b0b578697916414a869a029635fe5e0bab06b8f701a764c95e475c115ed12eb4f93c751d234b5868f4c4196d7db SHA512 8a60edb113d68791b41bd90b761ff7b3934260cb3dada3234c9351416f61394e4157353bc4d61b8f6c2c619de470f6feefffb4935bfcf79d291ece6285de7270
+DIST pixman-0.42.2.tar.xz 652984 BLAKE2B 6286a9d064a5a24017fccbb0a6e9f6ef932077c2e33ec043826d4a7a6c707c9111d3de4b806cbcdb47fc2794f1f930d24d078de1ff2912061967db0890540957 SHA512 3476e2676e66756b1af61b1e532cd80c985c191fb7956eb01702b419726cce99e79163b7f287f74f66414680e7396d13c3fee525cd663f12b6ac4877070ff4e8
diff --git a/x11-libs/pixman/pixman-0.42.2.ebuild b/x11-libs/pixman/pixman-0.42.2.ebuild
new file mode 100644
index 000000000000..0fbef29030a3
--- /dev/null
+++ b/x11-libs/pixman/pixman-0.42.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/pixman/pixman.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} flag-o-matic meson-multilib multiprocessing toolchain-funcs
+
+DESCRIPTION="Low-level pixel manipulation routines"
+HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+ SRC_URI="https://www.x.org/releases/individual/lib/${P}.tar.xz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="cpu_flags_ppc_altivec cpu_flags_arm_iwmmxt cpu_flags_arm_iwmmxt2 cpu_flags_arm_neon loongson2f cpu_flags_x86_mmxext cpu_flags_x86_sse2 cpu_flags_x86_ssse3 static-libs test"
+RESTRICT="!test? ( test )"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use test && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use test && tc-check-openmp
+}
+
+multilib_src_configure() {
+ if use arm && tc-is-clang ; then
+ # See bug #768138 and https://gitlab.freedesktop.org/pixman/pixman/-/issues/46
+ append-cflags $(test-flags-CC -fno-integrated-as)
+ fi
+
+ local emesonargs=(
+ $(meson_feature cpu_flags_arm_iwmmxt iwmmxt)
+ $(meson_use cpu_flags_arm_iwmmxt2 iwmmxt2)
+ $(meson_feature cpu_flags_x86_mmxext mmx)
+ $(meson_feature cpu_flags_x86_sse2 sse2)
+ $(meson_feature cpu_flags_x86_ssse3 ssse3)
+ $(meson_feature cpu_flags_ppc_altivec vmx)
+ $(meson_feature cpu_flags_arm_neon neon)
+ $(meson_feature cpu_flags_arm_neon a64-neon)
+ $(meson_feature loongson2f loongson-mmi)
+ $(meson_feature test openmp) # only used in unit tests
+ $(meson_feature test tests)
+ -Ddefault_library=$(usex static-libs both shared)
+ -Dgtk=disabled
+ -Dlibpng=disabled
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ export OMP_NUM_THREADS=$(makeopts_jobs)
+ meson_src_test -t 100
+}
diff --git a/x11-libs/pixman/pixman-9999.ebuild b/x11-libs/pixman/pixman-9999.ebuild
index ee72ddca48c6..0fbef29030a3 100644
--- a/x11-libs/pixman/pixman-9999.ebuild
+++ b/x11-libs/pixman/pixman-9999.ebuild
@@ -47,8 +47,10 @@ multilib_src_configure() {
$(meson_feature cpu_flags_x86_ssse3 ssse3)
$(meson_feature cpu_flags_ppc_altivec vmx)
$(meson_feature cpu_flags_arm_neon neon)
+ $(meson_feature cpu_flags_arm_neon a64-neon)
$(meson_feature loongson2f loongson-mmi)
$(meson_feature test openmp) # only used in unit tests
+ $(meson_feature test tests)
-Ddefault_library=$(usex static-libs both shared)
-Dgtk=disabled
-Dlibpng=disabled