summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-11 04:52:23 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-11 04:52:23 +0200
commitff82c8d0a0424b636d25a582de2e1418a82aa91f (patch)
treeb4e96eda052b519d31284397f70f45e5c0207571 /www-servers
parentdev-python/pyrate-limiter: Bump to 3.6.2 (diff)
downloadgentoo-ff82c8d0a0424b636d25a582de2e1418a82aa91f.tar.gz
gentoo-ff82c8d0a0424b636d25a582de2e1418a82aa91f.tar.bz2
gentoo-ff82c8d0a0424b636d25a582de2e1418a82aa91f.zip
www-servers/gunicorn: Bump to 23.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/gunicorn/Manifest1
-rw-r--r--www-servers/gunicorn/gunicorn-23.0.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/www-servers/gunicorn/Manifest b/www-servers/gunicorn/Manifest
index 2165a7251fe2..ff4e721f690e 100644
--- a/www-servers/gunicorn/Manifest
+++ b/www-servers/gunicorn/Manifest
@@ -1 +1,2 @@
DIST gunicorn-22.0.0.gh.tar.gz 368152 BLAKE2B 9d3e2955140d299af86b9370c352d0d7ae2b631a5cdf72200550d3ac8b2e5f51edbc686475d3507f8dfb5f4249ef261e29a6d5fa172e5356777297f5497c7c20 SHA512 cb366cfc2875a32e1e6ddd3bd521650cb87a51c29b036b2cfbd9f8371307d1ffefafbcc85d45753c29186a92def77112e2ddd49fdc2116d2d32702635e88ba53
+DIST gunicorn-23.0.0.gh.tar.gz 373550 BLAKE2B 5f7e74e3554e68863ac32225a95e2e83b69902013bb39f72dbcd150cb30b0698d4fbd2109d1b6e8858fe93b32f4a8aa52fa79cc7346ece769db5426c9caae840 SHA512 1304f348270134a5d9da0d6598f4878a25b3dd7ff96dc9eee1c07ec1031c03cd8bb3de42b6dedf63702588c7e482b18f88a3115e73005bbc4eaaad147d9674ba
diff --git a/www-servers/gunicorn/gunicorn-23.0.0.ebuild b/www-servers/gunicorn/gunicorn-23.0.0.ebuild
new file mode 100644
index 000000000000..a19a8dcda301
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-23.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="
+ https://gunicorn.org/
+ https://github.com/benoitc/gunicorn/
+ https://pypi.org/project/gunicorn/
+"
+SRC_URI="
+ https://github.com/benoitc/gunicorn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT PSF-2 doc? ( BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst )
+
+distutils_enable_sphinx 'docs/source' --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # removed deps
+ tests/workers/test_geventlet.py
+ tests/workers/test_ggevent.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts=
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/source/_build/html/. )
+
+ distutils-r1_python_install_all
+}