summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-06-01 10:20:54 +1000
committerMatt Jolly <kangie@gentoo.org>2024-06-01 10:42:26 +1000
commitb07732fc411f73372f4dda5241cbfe80c2cbfbf1 (patch)
tree1075bd54e310c0579e98934a4f529c47c18f7248 /www-client
parentsys-apps/fwupd: add 1.9.20, drop 1.9.18 (diff)
downloadgentoo-b07732fc411f73372f4dda5241cbfe80c2cbfbf1.tar.gz
gentoo-b07732fc411f73372f4dda5241cbfe80c2cbfbf1.tar.bz2
gentoo-b07732fc411f73372f4dda5241cbfe80c2cbfbf1.zip
www-client/dillo: new package, add 3.1.0, 9999
Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/dillo/Manifest2
-rw-r--r--www-client/dillo/dillo-3.1.0.ebuild102
-rw-r--r--www-client/dillo/dillo-9999.ebuild92
-rw-r--r--www-client/dillo/metadata.xml16
4 files changed, 212 insertions, 0 deletions
diff --git a/www-client/dillo/Manifest b/www-client/dillo/Manifest
new file mode 100644
index 000000000000..981e70c1e5e0
--- /dev/null
+++ b/www-client/dillo/Manifest
@@ -0,0 +1,2 @@
+DIST dillo-3.1.0-html-tests.tar.xz 46836 BLAKE2B cb5c4ac685bd816cb4adf416d42be1e10de2289ba9180dc2c3181353448ee9a3c043e39e8cede06ba1417f822678bfcea9b1cea73e76768a8934fbd90fa8b00f SHA512 af8625602aae52b209eb3d60fd536c8d5a630b36010fece933e77ab990f48e6d14e4b3bc4fda8df8e5e17e01990bebea3fa343a2e14ae8238b6486d658d6bbd2
+DIST dillo-3.1.0.tar.bz2 994610 BLAKE2B 02e5cd44163e5f066cbccf05a497439db6b7525cf612577908d435414f8a3dbbb4d7ab6a9345709dde5b278373f9d42f5a9f4143a32d5bcc49e2e4a7258a0f6d SHA512 c8a2ea420c2d70a60acc242cf15bd90e65c265db434f9693a1a8e7343cde1eb02c8144293c547582fb0985f306a07f11a7eb8e30c35ec2418131f717b1fda01f
diff --git a/www-client/dillo/dillo-3.1.0.ebuild b/www-client/dillo/dillo-3.1.0.ebuild
new file mode 100644
index 000000000000..b0a46b7df935
--- /dev/null
+++ b/www-client/dillo/dillo-3.1.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs virtualx
+
+DESCRIPTION="Lean FLTK based web browser"
+HOMEPAGE="https://dillo-browser.github.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dillo-browser/dillo.git"
+else
+ SRC_URI="
+ https://github.com/dillo-browser/dillo/releases/download/v${PV}/${P}.tar.bz2
+ test? ( https://deps.gentoo.zip/www-client/${P}-html-tests.tar.xz )
+ "
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug doc +gif +jpeg mbedtls +png +ssl +openssl +xembed"
+REQUIRED_USE="
+ ssl? ( || ( openssl mbedtls ) )
+"
+
+RDEPEND="
+ >=x11-libs/fltk-1.3:1
+ sys-libs/zlib
+ x11-libs/libX11
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ png? ( >=media-libs/libpng-1.2:= )
+ ssl? (
+ mbedtls? ( net-libs/mbedtls:= )
+ openssl? ( dev-libs/openssl:= )
+ )
+ test? (
+ media-gfx/imagemagick
+ x11-apps/xwd
+ x11-apps/xwininfo
+ )
+
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ doc? ( app-text/doxygen )
+"
+
+DOCS="AUTHORS ChangeLog README NEWS doc/*.txt doc/README"
+
+src_prepare() {
+ default
+ if use test; then
+ # https://github.com/dillo-browser/dillo/pull/176
+ # Upstream forgot to package tests for 3.1.0, I've done it
+ # so we'll just move them into place for this release.
+ rm -r "${S}"/test/html || die "Failed to remove broken test dir"
+ mv "${WORKDIR}"/html test/ || die "Failed to add good tests"
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug rtfl)
+ $(use_enable gif)
+ $(use_enable jpeg)
+ $(use_enable mbedtls)
+ $(use_enable openssl)
+ $(use_enable png)
+ $(use_enable ssl tls)
+ $(use_enable xembed)
+ --enable-ipv6
+ )
+
+ use test && myeconfargs+=( --enable-html-tests=yes )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
+}
+
+src_test() {
+ # The test suite consistently fails with -jN in portage
+ virtx emake -j1 check
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r html
+}
diff --git a/www-client/dillo/dillo-9999.ebuild b/www-client/dillo/dillo-9999.ebuild
new file mode 100644
index 000000000000..dc06be8e2058
--- /dev/null
+++ b/www-client/dillo/dillo-9999.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs virtualx
+
+DESCRIPTION="Lean FLTK based web browser"
+HOMEPAGE="https://dillo-browser.github.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dillo-browser/dillo.git"
+else
+ SRC_URI="https://github.com/dillo-browser/dillo/releases/download/v${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug doc +gif +jpeg mbedtls +png +ssl +openssl +xembed"
+REQUIRED_USE="
+ ssl? ( || ( openssl mbedtls ) )
+"
+
+RDEPEND="
+ >=x11-libs/fltk-1.3:1
+ sys-libs/zlib
+ x11-libs/libX11
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ png? ( >=media-libs/libpng-1.2:= )
+ ssl? (
+ mbedtls? ( net-libs/mbedtls:= )
+ openssl? ( dev-libs/openssl:= )
+ )
+ test? (
+ media-gfx/imagemagick
+ x11-apps/xwd
+ x11-apps/xwininfo
+ )
+
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ doc? ( app-text/doxygen )
+"
+
+DOCS="AUTHORS ChangeLog README NEWS doc/*.txt doc/README"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug rtfl)
+ $(use_enable gif)
+ $(use_enable jpeg)
+ $(use_enable mbedtls)
+ $(use_enable openssl)
+ $(use_enable png)
+ $(use_enable ssl tls)
+ $(use_enable xembed)
+ --enable-ipv6
+ )
+
+ use test && myeconfargs+=( --enable-html-tests=yes )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
+}
+
+src_test() {
+ # The test suite consistently fails with -jN in portage
+ virtx emake -j1 check
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r html
+}
diff --git a/www-client/dillo/metadata.xml b/www-client/dillo/metadata.xml
new file mode 100644
index 000000000000..3e919778f73f
--- /dev/null
+++ b/www-client/dillo/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>Kangie@gentoo.org</email>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <use>
+ <flag name="openssl">Build against the <pkg>dev-libs/openssl</pkg> library for TLS support.</flag>
+ <flag name="mbedtls">Build against the <pkg>net-libs/mbedtls</pkg> library for TLS support.</flag>
+ <flag name="xembed">Enable XEmbed protocol support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">dillo-browser/dillo</remote-id>
+ </upstream>
+</pkgmetadata>