summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-08-17 20:46:59 +0300
committerMart Raudsepp <leio@gentoo.org>2019-08-17 20:47:43 +0300
commit9185c2e148162ad577137c08a98721aa4078e7d8 (patch)
tree2af69043cb96ce9bfb58d7818b94787ef19abbe9 /www-client
parentgui-libs/libhandy: Initial import (diff)
downloadgentoo-9185c2e148162ad577137c08a98721aa4078e7d8.tar.gz
gentoo-9185c2e148162ad577137c08a98721aa4078e7d8.tar.bz2
gentoo-9185c2e148162ad577137c08a98721aa4078e7d8.zip
www-client/epiphany: bump to 3.32.4
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-3.32.4.ebuild84
-rw-r--r--www-client/epiphany/files/var-tmp-tests.patch13
3 files changed, 98 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 4cbd9fc3fa2e..cfbb3ae297b6 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1 +1,2 @@
DIST epiphany-3.30.4.tar.xz 4531732 BLAKE2B a4741d353800517c0233456e513a974ecd7641799395df7cafe6940cbfa49402836484010634ef3c59e36bd3bb2ced331d19a4ed05d1630c00d7ee385961227b SHA512 8574a26a22a24db7e65254f65723f6e4405fccd783bb7e122f8a5f6aff62d3ef1dd0b3ce903eb1f750e7ae28c2f1154a2c1c15970892216211d51edee318bd47
+DIST epiphany-3.32.4.tar.xz 5468576 BLAKE2B 8d9ed9f522a7f18c1e9b0fa6aea043c11e69eda8ee779e8cb05cbef1920154ee7e307ea92eac713c74f7a81a08d9fc31dfd3ba8fad59d5697f4aa652e12a6e8e SHA512 34f9f4267862b494cbeb225ce63cd7767851f1cca16b4c8e03057b074999954477f2ed891c60f20910abcc7a553371f8f03e59fc9da4cf459dd5cbfde8a6d67c
diff --git a/www-client/epiphany/epiphany-3.32.4.ebuild b/www-client/epiphany/epiphany-3.32.4.ebuild
new file mode 100644
index 000000000000..c69aaaf7987a
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.32.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-libs/glib-2.56.0:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=dev-libs/nettle-3.4:=
+ >=net-libs/webkit-gtk-2.24.1:4=
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.5.5:=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ gnome-base/gsettings-desktop-schemas
+ dev-libs/icu:=
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.2.4
+ >=dev-libs/libdazzle-3.31.90
+ >=gui-libs/libhandy-0.0.9:0.0=
+ >=x11-libs/libnotify-0.5.1
+ >=app-crypt/libsecret-0.14
+ >=net-libs/libsoup-2.48.0:2.4
+ >=dev-libs/libxml2-2.6.12:2
+ dev-db/sqlite:3
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Allow /var/tmp prefixed recursive delete (due to package manager setting TMPDIR)
+ "${FILESDIR}"/var-tmp-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/www-client/epiphany/files/var-tmp-tests.patch b/www-client/epiphany/files/var-tmp-tests.patch
new file mode 100644
index 000000000000..f2a0d97aaf96
--- /dev/null
+++ b/www-client/epiphany/files/var-tmp-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/tests/ephy-file-helpers-test.c b/tests/ephy-file-helpers-test.c
+index b3139b67e..10c884ea5 100644
+--- a/tests/ephy-file-helpers-test.c
++++ b/tests/ephy-file-helpers-test.c
+@@ -87,7 +87,7 @@ test_ephy_file_helpers_init (void)
+ if (keep_dir) {
+ /* As a safety measure, only try recursive delete on paths
+ * prefixed with /tmp. */
+- if (g_str_has_prefix (tmp_dir, "/tmp"))
++ if (g_str_has_prefix (tmp_dir, "/tmp") || g_str_has_prefix (tmp_dir, "/var/tmp"))
+ g_assert_true (ephy_file_delete_dir_recursively (tmp_dir, NULL));
+ else
+ g_warning ("INIT: dangerous path returned as tmp_dir: %s", tmp_dir);