summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-09 16:58:32 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-09 17:22:46 +1000
commit2b646e613de013ac94dbfb10146bcb769a759bf3 (patch)
tree10ef7185fad5ea2f488d9c5db407d9555241f958 /www-client
parenttoolchain.eclass: call rust_pkg_setup for USE=rust (diff)
downloadgentoo-2b646e613de013ac94dbfb10146bcb769a759bf3.tar.gz
gentoo-2b646e613de013ac94dbfb10146bcb769a759bf3.tar.bz2
gentoo-2b646e613de013ac94dbfb10146bcb769a759bf3.zip
www-client/firefox: 132: fix LTO check on USE=pgo path
Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-132.0-r1.ebuild2
-rw-r--r--www-client/firefox/firefox-132.0.1-r1.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/www-client/firefox/firefox-132.0-r1.ebuild b/www-client/firefox/firefox-132.0-r1.ebuild
index f99bf2798680..858c6586a808 100644
--- a/www-client/firefox/firefox-132.0-r1.ebuild
+++ b/www-client/firefox/firefox-132.0-r1.ebuild
@@ -472,7 +472,7 @@ pkg_setup() {
fi
if use pgo ; then
- if [[ ${use_lto} == "yes" ]]; then
+ if [[ ${use_lto} == "no" ]]; then
eerror "Building ${PN} with USE=pgo requires LTO!"
die "Please fix your CFLAGS/CXXFLAGS."
fi
diff --git a/www-client/firefox/firefox-132.0.1-r1.ebuild b/www-client/firefox/firefox-132.0.1-r1.ebuild
index 3c8bc526fd20..c767c09e4a2a 100644
--- a/www-client/firefox/firefox-132.0.1-r1.ebuild
+++ b/www-client/firefox/firefox-132.0.1-r1.ebuild
@@ -470,7 +470,7 @@ pkg_setup() {
fi
if use pgo ; then
- if [[ ${use_lto} == "yes" ]]; then
+ if [[ ${use_lto} == "no" ]]; then
eerror "Building ${PN} with USE=pgo requires LTO!"
die "Please fix your CFLAGS/CXXFLAGS."
fi