summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-client/w3mir
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-client/w3mir')
-rw-r--r--www-client/w3mir/Manifest1
-rw-r--r--www-client/w3mir/files/w3mir-1.0.10-cwd.diff32
-rw-r--r--www-client/w3mir/metadata.xml8
-rw-r--r--www-client/w3mir/w3mir-1.0.10-r2.ebuild25
4 files changed, 66 insertions, 0 deletions
diff --git a/www-client/w3mir/Manifest b/www-client/w3mir/Manifest
new file mode 100644
index 000000000000..35815ceffea8
--- /dev/null
+++ b/www-client/w3mir/Manifest
@@ -0,0 +1 @@
+DIST w3mir-1.0.10.tar.gz 82791 SHA256 c6a58939a89b2b469db54c639e63438f4fcba3c79ebcea69675d7115ba48369d SHA512 01d579f9e9b4472f2ed51e5d980d29fca9957004a946a5608ffc417930fed7cc545cd2f924ce2f2a3ad5fe2e64792bc2b95b133d883f9fa7d5b30247e5f2aa10 WHIRLPOOL 50c7a5d6a181b7a724c562d2f0346074113f17cbefda95c74a1e2b243527cd226b1ad9ee2dba22090bbf707e166811025037f9dea397520600af499812995502
diff --git a/www-client/w3mir/files/w3mir-1.0.10-cwd.diff b/www-client/w3mir/files/w3mir-1.0.10-cwd.diff
new file mode 100644
index 000000000000..83c3781efc43
--- /dev/null
+++ b/www-client/w3mir/files/w3mir-1.0.10-cwd.diff
@@ -0,0 +1,32 @@
+--- w3mir.PL 2005-12-10 20:39:58.000000000 +0100
++++ w3mir.PL 2005-12-11 12:49:26.000000000 +0100
+@@ -209,6 +209,8 @@
+ use URI::URL;
+ # For flush method
+ use FileHandle;
++# for determining current working directory
++use Cwd;
+
+ eval '
+ use URI;
+@@ -581,7 +583,8 @@
+ unless ref $rum_url_o;
+
+ # Derive a filename from the url, the filename contains no URL-quoting
+- my($lf_name) = (url "file:$lf_url")->unix_path;
++ # filename is relative to current working directory
++ my($lf_name) = (url "file:".getcwd()."/$lf_url")->unix_path;
+
+ # Make all intermediate directories
+ &mkdir($lf_name) if $s==0;
+@@ -680,9 +683,7 @@
+ push(@EXTRASTUFF,$w3http::NOUSER)
+ unless ($do_user);
+
+- # YES, $lf_url is right, w3http::query handles this like an url so
+- # the quoting must all be in place.
+- my $binfile=$lf_url;
++ my $binfile=$lf_name;
+ $binfile='-' if $s==1;
+ $binfile=$nulldevice if $s==2;
+
diff --git a/www-client/w3mir/metadata.xml b/www-client/w3mir/metadata.xml
new file mode 100644
index 000000000000..59e2b8f78cb5
--- /dev/null
+++ b/www-client/w3mir/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/www-client/w3mir/w3mir-1.0.10-r2.ebuild b/www-client/w3mir/w3mir-1.0.10-r2.ebuild
new file mode 100644
index 000000000000..87f30289f999
--- /dev/null
+++ b/www-client/w3mir/w3mir-1.0.10-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils perl-app
+
+DESCRIPTION="w3mir is a all purpose HTTP copying and mirroring tool"
+SRC_URI="http://langfeldt.net/w3mir/${P}.tar.gz"
+HOMEPAGE="http://langfeldt.net/w3mir/"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="alpha ~amd64 ppc ~sparc x86 ~arm-linux ~x86-linux"
+
+DEPEND="${DEPEND}
+ >=dev-perl/URI-1.0.9
+ >=dev-perl/libwww-perl-5.64-r1
+ >=virtual/perl-MIME-Base64-2.12"
+
+src_prepare() {
+
+ epatch "${FILESDIR}/${P}-cwd.diff"
+}