summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2021-05-19 09:34:37 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-06-07 14:05:05 +0300
commit7aa3ad8101eb97eb81c929f6ecc424e79ff6cce6 (patch)
tree6dded78576e24d7d7c7e2b33dd9559200979c371 /www-client/surf
parentnet-misc/youtube-dl-9999: fix inherit order following the previous commit (diff)
downloadgentoo-7aa3ad8101eb97eb81c929f6ecc424e79ff6cce6.tar.gz
gentoo-7aa3ad8101eb97eb81c929f6ecc424e79ff6cce6.tar.bz2
gentoo-7aa3ad8101eb97eb81c929f6ecc424e79ff6cce6.zip
www-client/surf: update live
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-client/surf')
-rw-r--r--www-client/surf/surf-9999.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/www-client/surf/surf-9999.ebuild b/www-client/surf/surf-9999.ebuild
index d6b737a623dc..19c3211f6090 100644
--- a/www-client/surf/surf-9999.ebuild
+++ b/www-client/surf/surf-9999.ebuild
@@ -2,40 +2,44 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 savedconfig toolchain-funcs
+inherit savedconfig toolchain-funcs
DESCRIPTION="a simple web browser based on WebKit/GTK+"
HOMEPAGE="https://surf.suckless.org/"
-EGIT_REPO_URI="https://git.suckless.org/surf"
-EGIT_BRANCH="surf-webkit2"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.suckless.org/surf"
+ EGIT_BRANCH="surf-webkit2"
+else
+ SRC_URI="https://dl.suckless.org/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
IUSE="tabbed"
-COMMON_DEPEND="
+DEPEND="
app-crypt/gcr[gtk]
dev-libs/glib:2
net-libs/webkit-gtk:4
x11-libs/gtk+:3
x11-libs/libX11
"
-DEPEND="
- ${COMMON_DEPEND}
- virtual/pkgconfig
-"
-RDEPEND="
+RDEPEND="${DEPEND}
!sci-chemistry/surf
- ${COMMON_DEPEND}
!savedconfig? (
- >=x11-misc/dmenu-4.7
net-misc/curl
x11-apps/xprop
+ x11-misc/dmenu
x11-terms/st
)
tabbed? ( x11-misc/tabbed )
"
+BDEPEND="
+ virtual/pkgconfig
+"
PATCHES=(
"${FILESDIR}"/${PN}-9999-gentoo.patch
)