summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-09-24 23:25:19 +0100
committerJames Le Cuirot <chewi@gentoo.org>2021-09-24 23:25:34 +0100
commitea34c47250e9a12e560ab11a9b3f092bfd9b9ee1 (patch)
tree3ba789d6a685746ee3a767d05c1a6817fbe239d8 /www-apps/xpra-html5/xpra-html5-4.5.1.ebuild
parentdev-libs/weston: Drop old 9.0.0 (diff)
downloadgentoo-ea34c47250e9a12e560ab11a9b3f092bfd9b9ee1.tar.gz
gentoo-ea34c47250e9a12e560ab11a9b3f092bfd9b9ee1.tar.bz2
gentoo-ea34c47250e9a12e560ab11a9b3f092bfd9b9ee1.zip
www-apps/xpra-html5: Bump to 4.5.1, drop old 4.5
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'www-apps/xpra-html5/xpra-html5-4.5.1.ebuild')
-rw-r--r--www-apps/xpra-html5/xpra-html5-4.5.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/www-apps/xpra-html5/xpra-html5-4.5.1.ebuild b/www-apps/xpra-html5/xpra-html5-4.5.1.ebuild
new file mode 100644
index 000000000000..9fa65b5197fd
--- /dev/null
+++ b/www-apps/xpra-html5/xpra-html5-4.5.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit python-any-r1
+
+DESCRIPTION="HTML5 client to connect to any xpra server"
+HOMEPAGE="https://xpra.org/"
+SRC_URI="https://github.com/Xpra-org/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="brotli +gzip minify"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ brotli? ( app-arch/brotli )
+ minify? ( dev-util/uglifyjs )
+"
+
+src_configure() {
+ cat <<EOF > vcs-info || die
+BRANCH=gentoo
+REVISION=${PR#r}
+LOCAL_MODIFICATIONS=0
+EOF
+}
+
+src_install() {
+ "${PYTHON}" <<EOF || die
+import setup
+setup.set_version("${PV}")
+setup.install_html5(
+ "${ED}/usr/share/xpra/www",
+ "$(usex minify uglifyjs copy)",
+ brotli=$(usex brotli True False),
+ gzip=$(usex gzip True False)
+)
+EOF
+}