summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2022-08-09 09:05:24 -0400
committerCraig Andrews <candrews@gentoo.org>2022-08-09 09:11:50 -0400
commit6789aeb67512f40051f548151d75d2389904848d (patch)
tree689f16c394640cf918d55ad5aa43032dca1402a6 /www-apps/sonarr
parentapp-backup/btrbk: add 0.32.3 (diff)
downloadgentoo-6789aeb67512f40051f548151d75d2389904848d.tar.gz
gentoo-6789aeb67512f40051f548151d75d2389904848d.tar.bz2
gentoo-6789aeb67512f40051f548151d75d2389904848d.zip
www-apps/sonarr: add 3.0.9.1549
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apps/sonarr')
-rw-r--r--www-apps/sonarr/Manifest1
-rw-r--r--www-apps/sonarr/sonarr-3.0.9.1549.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/www-apps/sonarr/Manifest b/www-apps/sonarr/Manifest
index 02cb272ebb45..87616d67142a 100644
--- a/www-apps/sonarr/Manifest
+++ b/www-apps/sonarr/Manifest
@@ -1 +1,2 @@
DIST Sonarr.main.3.0.8.1507.linux.tar.gz 13647325 BLAKE2B bd269ec2e628075548c9c11db0f9d31f0b9a8c24bb55e0b7d0c58cc32c33423ca4988e9e63170fa6b5f49d438877a88402cebca3183fb98ac5995eb2a38e96e5 SHA512 32efec2207e853a1d7737fc72e9484e62c07a4b39f7e9c6ea0519bcc3220bf4bdb189c6b5dc30aa168912ba912a78c4c5832e2b84bc0a42c46844e76d3b9cc1a
+DIST Sonarr.main.3.0.9.1549.linux.tar.gz 14105679 BLAKE2B 97aa7e5a3836e66433b49e6128779acfe6985fba029a17835a9de31708793752f0f7f59269697f97210994d566708aea2147f199e4d0f51a845c60918d236bfe SHA512 ee97eaa9f2864387619091656843cb57610ada9fd6ad01da3c5414a876ad3b2257572711b2d113477983fcd7456a8eed962bd05928124c6fd9fc66cb80aab170
diff --git a/www-apps/sonarr/sonarr-3.0.9.1549.ebuild b/www-apps/sonarr/sonarr-3.0.9.1549.ebuild
new file mode 100644
index 000000000000..d458ea49dd86
--- /dev/null
+++ b/www-apps/sonarr/sonarr-3.0.9.1549.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+SRC_URI="https://download.sonarr.tv/v3/main/${PV}/Sonarr.main.${PV}.linux.tar.gz"
+
+DESCRIPTION="Sonarr is a Smart PVR for newsgroup and bittorrent users"
+HOMEPAGE="https://www.sonarr.tv"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="bindist strip test"
+
+RDEPEND="
+ acct-group/sonarr
+ acct-user/sonarr
+ >=dev-lang/mono-6.6.0.161
+ media-video/mediainfo
+ dev-db/sqlite"
+
+QA_PREBUILT="*"
+
+S="${WORKDIR}/Sonarr"
+
+src_install() {
+ newinitd "${FILESDIR}/${PN}.init" ${PN}
+
+ keepdir /var/lib/${PN}
+ fowners -R ${PN}:${PN} /var/lib/${PN}
+
+ insinto /etc/logrotate.d
+ insopts -m0644 -o root -g root
+ newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+ dodir "/opt/${PN}"
+ cp -R "${S}/." "${D}/opt/${PN}" || die "Install failed!"
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_newunit "${FILESDIR}/${PN}.service" "${PN}@.service"
+}