summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-06-25 07:51:03 +0200
committerHans de Graaff <graaff@gentoo.org>2023-06-25 07:51:19 +0200
commite4c84fd0da3fadc18960285b4a95b1bb316d4046 (patch)
tree528e5259ffaef4e4611859f10b74944bc6a076ac /www-apps/nanoc
parentwww-apps/nanoc-core: add 4.12.16 (diff)
downloadgentoo-e4c84fd0da3fadc18960285b4a95b1bb316d4046.tar.gz
gentoo-e4c84fd0da3fadc18960285b4a95b1bb316d4046.tar.bz2
gentoo-e4c84fd0da3fadc18960285b4a95b1bb316d4046.zip
www-apps/nanoc: add 4.12.16
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'www-apps/nanoc')
-rw-r--r--www-apps/nanoc/Manifest1
-rw-r--r--www-apps/nanoc/nanoc-4.12.16.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/www-apps/nanoc/Manifest b/www-apps/nanoc/Manifest
index 9451b1ee48b1..21edc8ac5f6c 100644
--- a/www-apps/nanoc/Manifest
+++ b/www-apps/nanoc/Manifest
@@ -1,2 +1,3 @@
DIST nanoc-4.12.14.tar.gz 347902 BLAKE2B 325560667b370df0b245523463be8d5e9cda0cbfbe224e790f84c98aab21eee85a87fce962a24fc975cd98b0b68ad8611fe5c42cc4e0001fe4b6b17ab59bbc1a SHA512 bbc54d84f50cb7586467e33db5986ae9c93ba402b102d159864f78cfb2f3102cea736a5b89655345da93b6dfe1576aa188eba143d206a747bbff38dc27a4b2f9
DIST nanoc-4.12.15.tar.gz 348052 BLAKE2B a880b3f5e3f8dc59e0a98d5e957ad6ca64134cc54c2a6e4380e91ce64414c93e8212ee2724b646703ada4ff212576346b9dd3b272cf6adc35d58e1277ab185c8 SHA512 43e37005306b137162786f14c54690888845eeee582cedb9947c7cd6baf0c1cc83a51529af89fef48843960726cb04aba6cd0e41b2b2a92615543a303b864150
+DIST nanoc-4.12.16.tar.gz 350823 BLAKE2B 8196589290b5120b74bd2063e60f1fad14af98f7c8ffcef0a226d28ecb3f129ab04c913ad921e64c9551965c8fe1e26da1e0f41baa64a75caa372d6796c5084b SHA512 e04a562d87250286a9fbdc0381fdc64868f87f67d1ae9ce81f0e21c13496e168cfc4936c02b3cba87e8d647ab070670a208722fd53f4265eb3674b7ba20ccebd
diff --git a/www-apps/nanoc/nanoc-4.12.16.ebuild b/www-apps/nanoc/nanoc-4.12.16.ebuild
new file mode 100644
index 000000000000..826e15fcb9cf
--- /dev/null
+++ b/www-apps/nanoc/nanoc-4.12.16.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="nanoc.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="nanoc is a simple but very flexible static site generator written in Ruby"
+HOMEPAGE="https://nanoc.app/"
+SRC_URI="https://github.com/nanoc/nanoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="${IUSE} minimal"
+
+DEPEND+="test? ( app-text/asciidoc app-text/highlight )"
+
+RUBY_S="${P}/nanoc"
+
+ruby_add_rdepend "!minimal? (
+ dev-ruby/mime-types:*
+ dev-ruby/rack:*
+ www-servers/adsf
+)
+ >=dev-ruby/addressable-2.5
+ >=dev-ruby/colored-1.2:0
+ >=www-apps/nanoc-checking-1.0.2:1
+ ~www-apps/nanoc-cli-${PV}
+ ~www-apps/nanoc-core-${PV}
+ www-apps/nanoc-deploying:1
+ >=dev-ruby/parallel-1.12:1
+ >=dev-ruby/tty-command-0.8:0
+ >=dev-ruby/tty-which-0.4:0
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec:3
+ dev-ruby/asciidoctor
+ dev-ruby/fuubar
+ dev-ruby/haml
+ dev-ruby/maruku
+ >=dev-ruby/mocha-0.13
+ dev-ruby/minitest
+ dev-ruby/mustache
+ dev-ruby/pry
+ dev-ruby/rdoc
+ >=dev-ruby/rouge-3.5.1:2
+ dev-ruby/rubypants
+ dev-ruby/systemu
+ dev-ruby/timecop
+ dev-ruby/vcr
+ dev-ruby/webmock
+ dev-ruby/yard
+)
+doc? (
+ dev-ruby/kramdown
+ dev-ruby/rdiscount
+ dev-ruby/yard
+)"
+
+all_ruby_prepare() {
+ # Avoid unneeded development dependencies
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '/codecov/I s:^:#:' test/helper.rb ../common/spec/spec_helper_head_core.rb || die
+ sed -i -e '/coverall/I s:^:#:' \
+ -e '/rubocop/ s:^:#:' Rakefile || die
+ sed -i -e '2igem "psych", "~> 4.0"' test/helper.rb || die
+
+ echo "-r ./spec/spec_helper.rb" > .rspec || die
+
+ # Avoid basepath issues when generating gemspec
+ sed -i -e "s:require_relative ':require './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid tests requiring a network connection or make assumptions
+ # about the local network environment.
+ rm -f test/checking/checks/test_{css,html}.rb spec/nanoc/cli/commands/view_spec.rb || die
+
+ # Avoid tests for unpackaged dependencies
+ rm spec/nanoc/filters/less_spec.rb \
+ test/filters/test_{markaby,rainpress}.rb || die
+
+ # Avoid tests that are specific to haml 6.x which is currently not packaged
+ sed -i -e '/test_filter_\(with_proper_indentation\|error\)/askip "haml 6"' test/filters/test_haml.rb || die
+
+ # Avoid non-fatal failing tests due to specifics in the environment
+ sed -e '124askip "ordering issues"' -e '168askip "ordering issues"' \
+ -i spec/nanoc/data_sources/filesystem_spec.rb || die
+ sed -e '/def test_default_encoding/,/^ end/ s:^:#:' \
+ -i test/orig_cli/commands/test_create_site.rb || die
+}
+
+each_ruby_test() {
+ MT_NO_PLUGINS=true RUBYLIB="${S}/lib" ${RUBY} -S rake spec test_all || die
+}