summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/jekyll
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/jekyll')
-rw-r--r--www-apps/jekyll/Manifest1
-rw-r--r--www-apps/jekyll/jekyll-2.5.3.ebuild56
-rw-r--r--www-apps/jekyll/metadata.xml11
3 files changed, 68 insertions, 0 deletions
diff --git a/www-apps/jekyll/Manifest b/www-apps/jekyll/Manifest
new file mode 100644
index 000000000000..2e6a709b686e
--- /dev/null
+++ b/www-apps/jekyll/Manifest
@@ -0,0 +1 @@
+DIST jekyll-2.5.3.tar.gz 757248 SHA256 51316d48c3b12a6753a66655e1c7676f2c1014f0b50ccff6bf53002d5934b93d SHA512 28dc09ec9e758fbd2637df9e2adbd139af77799ace6af32d1ae4834ac9fb08e1a10f286a274a5faa589a37451fac5e8187cd219950be36c0e9b8bbdcbfd31285 WHIRLPOOL f8c1a43be364893b811e8a23e4aacf032d17e0dce01d8a253a2ed05f008141cc99181cd5c8922307d296804b961880ba29a839b3c263856d040160f80ac81771
diff --git a/www-apps/jekyll/jekyll-2.5.3.ebuild b/www-apps/jekyll/jekyll-2.5.3.ebuild
new file mode 100644
index 000000000000..2f4079bafb2e
--- /dev/null
+++ b/www-apps/jekyll/jekyll-2.5.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.markdown README.markdown History.markdown"
+RUBY_FAKEGEM_EXTRAINSTALL="features site"
+
+DESCRIPTION="A simple, blog aware, static site generator"
+HOMEPAGE="http://jekyllrb.com http://github.com/jekyll/jekyll"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "dev-ruby/classifier-reborn
+ dev-ruby/colorator
+ >=dev-ruby/kramdown-1.3
+ >=dev-ruby/liquid-2.6.1:0
+ >=dev-ruby/mercenary-0.3.3
+ >=dev-ruby/pygments_rb-0.6.0
+ >=dev-ruby/redcarpet-3.1
+ >=dev-ruby/safe_yaml-1
+ dev-ruby/toml
+ www-apps/jekyll-coffeescript
+ www-apps/jekyll-gist
+ www-apps/jekyll-paginate
+ www-apps/jekyll-sass-converter
+ www-apps/jekyll-watch"
+
+ruby_add_bdepend "test? (
+ dev-ruby/activesupport:3.2
+ dev-ruby/launchy
+ >=dev-ruby/maruku-0.7
+ dev-ruby/mime-types:0
+ =dev-ruby/rdiscount-1.6*
+ >=dev-ruby/redcloth-4.2.1
+ >=dev-ruby/rouge-1.7
+ dev-ruby/rr
+ >=dev-ruby/shoulda-3
+ dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/,+5d" test/helper.rb || die
+ sed -i -e "1igem 'test-unit'" test/helper.rb || die
+ # Drop bundler
+ sed -i -e "/self.class.require_from_bundler/d" lib/jekyll/plugin_manager.rb || die
+ # This test fails without bundler
+ rm test/test_plugin_manager.rb || die
+}
diff --git a/www-apps/jekyll/metadata.xml b/www-apps/jekyll/metadata.xml
new file mode 100644
index 000000000000..159cb86f6181
--- /dev/null
+++ b/www-apps/jekyll/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jekyll/jekyll</remote-id>
+ </upstream>
+</pkgmetadata>