summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-06-13 11:46:14 -0400
committerCraig Andrews <candrews@gentoo.org>2023-06-13 11:46:28 -0400
commitdf7b7e6e5a71b8c21bfc483d6512389eaa1d732f (patch)
tree9a36e45300999916bf207a29aeb1ee46ec6cb8af /www-apache
parentdev-python/python-rtmidi: add 1.5.1 (diff)
downloadgentoo-df7b7e6e5a71b8c21bfc483d6512389eaa1d732f.tar.gz
gentoo-df7b7e6e5a71b8c21bfc483d6512389eaa1d732f.tar.bz2
gentoo-df7b7e6e5a71b8c21bfc483d6512389eaa1d732f.zip
www-apache/mod_h2: add 2.0.19
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-2.0.19.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index 88e84a4c3215..b2b995d0b4d7 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1 +1,2 @@
DIST mod_h2-2.0.18.tar.gz 798216 BLAKE2B f57116608da33a73f0e8811a78318234afaed69dea479503bd022096748d8604b744255b406b5025ed9a4bbbb78175b8c9c44a78af538d749bad46c0f8b141b6 SHA512 6e44a27722977e2ff9339a51557644072c3b154134b8273519b8f0de29759e9a7c982e92f66c9746bd34818b86089ae19f62980816853b576c8fb71b1ec5ea2d
+DIST mod_h2-2.0.19.tar.gz 798975 BLAKE2B 5cb0e5d247db93375e9240b144b2e156720cc5beb15e1720c7c30b46eda0e7021371b9194f78a6aed97b53dbd6c9338ce3e612c13e8ff71f9b16bf9c610fc9dd SHA512 eec50f6c71ab15d918749845e1491b199e31ae4d9baa2821c572dc9f8d6d5ad5b751409f06040a76c94574b174b952b30c9d982e6706e1dddda6974833c3915a
diff --git a/www-apache/mod_h2/mod_h2-2.0.19.ebuild b/www-apache/mod_h2/mod_h2-2.0.19.ebuild
new file mode 100644
index 000000000000..5ba43634b8e0
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-2.0.19.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}