summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-08-09 21:12:02 +0200
committerAnthony G. Basile <blueness@gentoo.org>2018-08-09 15:17:08 -0400
commite8d12fcb6ab10c84f14ad2cc25edfd372fd4239a (patch)
tree0df7eccefe665d16763865a5a8708dc2651f77b0 /sys-process
parentnet-misc/openvswitch: add missing versionator inherit (diff)
downloadgentoo-e8d12fcb6ab10c84f14ad2cc25edfd372fd4239a.tar.gz
gentoo-e8d12fcb6ab10c84f14ad2cc25edfd372fd4239a.tar.bz2
gentoo-e8d12fcb6ab10c84f14ad2cc25edfd372fd4239a.zip
sys-process/dcron: fix qa warning
Also bump to EAPI="6". Closes: https://bugs.gentoo.org/651202 Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/dcron/dcron-4.5-r2.ebuild52
-rw-r--r--sys-process/dcron/metadata.xml20
2 files changed, 66 insertions, 6 deletions
diff --git a/sys-process/dcron/dcron-4.5-r2.ebuild b/sys-process/dcron/dcron-4.5-r2.ebuild
new file mode 100644
index 000000000000..e0d83c3e1c1b
--- /dev/null
+++ b/sys-process/dcron/dcron-4.5-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cron toolchain-funcs systemd
+
+DESCRIPTION="A cute little cron from Matt Dillon"
+HOMEPAGE="http://www.jimpryor.net/linux/dcron.html http://apollo.backplane.com/FreeSrc/"
+SRC_URI="http://www.jimpryor.net/linux/releases/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+DOCS=( CHANGELOG README extra/run-cron extra/root.crontab "${FILESDIR}"/crontab )
+
+PATCHES=( "${FILESDIR}"/${PN}-4.5-ldflags.patch "${FILESDIR}"/${PN}-4.5-pidfile.patch )
+
+src_prepare() {
+ default
+
+ tc-export CC
+
+ cat <<-EOF > config
+ PREFIX = /usr
+ CRONTAB_GROUP = cron
+ EOF
+}
+
+src_install() {
+ default
+
+ docrondir
+ docron crond -m0700 -o root -g wheel
+ docrontab
+
+ insinto /etc
+ doins "${FILESDIR}"/crontab
+
+ insinto /etc/cron.d
+ doins extra/prune-cronstamps
+
+ insinto /etc/logrotate.d
+ newins extra/crond.logrotate dcron
+
+ keepdir /var/spool/cron/cronstamps
+
+ newinitd "${FILESDIR}"/dcron.init dcron
+ newconfd "${FILESDIR}"/dcron.confd dcron
+ systemd_dounit "${FILESDIR}"/dcron.service
+}
diff --git a/sys-process/dcron/metadata.xml b/sys-process/dcron/metadata.xml
index 4fc1e843e09b..2cfaa1da1d06 100644
--- a/sys-process/dcron/metadata.xml
+++ b/sys-process/dcron/metadata.xml
@@ -1,10 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>cron-bugs@gentoo.org</email>
-</maintainer>
-<upstream>
- <remote-id type="github">dubiousjim/dcron</remote-id>
-</upstream>
+ <maintainer type="project">
+ <email>cron-bugs@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This lightweight cron daemon aims to be simple and secure, with just enough
+ features to stay useful.
+ Unlike other fatter cron daemons, though, this cron doesn't even try to manage
+ environment variables or act as a shell.
+ All jobs are run with `/bin/sh` for conformity and portability.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/dubiousjim/dcron/issues</bugs-to>
+ <remote-id type="github">dubiousjim/dcron</remote-id>
+ </upstream>
</pkgmetadata>