summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-24 10:22:51 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-24 10:23:05 +0200
commita8826981f1b9597bbb2b6fb64527f6fd1defc694 (patch)
tree8fa8042d78317590d5cbdddf57b7e0350154ac10 /sys-process
parentsys-process/htop: Enable py3.7 (diff)
downloadgentoo-a8826981f1b9597bbb2b6fb64527f6fd1defc694.tar.gz
gentoo-a8826981f1b9597bbb2b6fb64527f6fd1defc694.tar.bz2
gentoo-a8826981f1b9597bbb2b6fb64527f6fd1defc694.zip
sys-process/htop: Use python-any-r1 eclass
Closes: https://bugs.gentoo.org/661946 Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/htop-3.0.0_beta4.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-process/htop/htop-3.0.0_beta4.ebuild b/sys-process/htop/htop-3.0.0_beta4.ebuild
index e2ada9cf173e..fff66cbf7257 100644
--- a/sys-process/htop/htop-3.0.0_beta4.ebuild
+++ b/sys-process/htop/htop-3.0.0_beta4.ebuild
@@ -5,7 +5,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
-inherit autotools linux-info python-single-r1
+inherit autotools linux-info python-any-r1
DESCRIPTION="interactive process viewer"
HOMEPAGE="https://hisham.hm/htop/"
@@ -39,11 +39,11 @@ PATCHES=(
pkg_setup() {
if ! has_version sys-process/lsof; then
- ewarn "To use lsof features in htop(what processes are accessing"
+ ewarn "To use lsof features in htop (what processes are accessing"
ewarn "what files), you must have sys-process/lsof installed."
fi
- python-single-r1_pkg_setup
+ python-any-r1_pkg_setup
linux-info_pkg_setup
}