summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-17 01:55:13 +0000
committerSam James <sam@gentoo.org>2024-11-17 01:55:13 +0000
commit445d56b1f8a0227ce3654b5eaac415fcc5a232ca (patch)
treeade298bd43a696c543f7a1614062650f6697bd27 /sys-process
parentdev-util/unifdef: fix C23 compat (diff)
downloadgentoo-445d56b1f8a0227ce3654b5eaac415fcc5a232ca.tar.gz
gentoo-445d56b1f8a0227ce3654b5eaac415fcc5a232ca.tar.bz2
gentoo-445d56b1f8a0227ce3654b5eaac415fcc5a232ca.zip
sys-process/time: build with -std=gnu17
Bug: https://savannah.gnu.org/bugs/index.php?66450 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/time/time-1.9-r1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/sys-process/time/time-1.9-r1.ebuild b/sys-process/time/time-1.9-r1.ebuild
index 7eea0b8d8d24..530fc7a3d101 100644
--- a/sys-process/time/time-1.9-r1.ebuild
+++ b/sys-process/time/time-1.9-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit flag-o-matic
+
DESCRIPTION="Displays info about resources used by a program"
HOMEPAGE="https://www.gnu.org/directory/time.html"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
@@ -16,3 +18,10 @@ BDEPEND="sys-apps/texinfo"
PATCHES=(
"${FILESDIR}"/${PN}-1.9-implicit-func-decl-clang.patch
)
+
+src_configure() {
+ # https://savannah.gnu.org/bugs/index.php?66450
+ append-cflags -std=gnu17
+
+ econf
+}