summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-21 12:38:18 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-21 12:38:18 +0300
commite16723ebd669c84a2ceb84e268beea98b84d9b2b (patch)
tree403318db98e476f302af478771174807af8df392 /sys-process/iotop-c
parentapp-arch/dpkg: Keyword 1.20.9 for ~m68k (diff)
downloadgentoo-e16723ebd669c84a2ceb84e268beea98b84d9b2b.tar.gz
gentoo-e16723ebd669c84a2ceb84e268beea98b84d9b2b.tar.bz2
gentoo-e16723ebd669c84a2ceb84e268beea98b84d9b2b.zip
sys-process/iotop-c: add 1.19
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-process/iotop-c')
-rw-r--r--sys-process/iotop-c/Manifest1
-rw-r--r--sys-process/iotop-c/iotop-c-1.19.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-process/iotop-c/Manifest b/sys-process/iotop-c/Manifest
index 4c6717c0a8cb..1eddfc18a3eb 100644
--- a/sys-process/iotop-c/Manifest
+++ b/sys-process/iotop-c/Manifest
@@ -1 +1,2 @@
DIST iotop-c-1.18.tar.gz 114838 BLAKE2B 8b3e13d00de4a5cd385a2d441d84bb27cc1d03a27012163b9628285c31176698bf840951e39199abef11b2d3c0413d500d6e7699f32a3b542360a1333307d00e SHA512 f0affbfdb106eb36078e7994860155f52d47878017f47e64d69aa7c04cc29756ca516a6634fd19d6d39c931100b9a0e93e07ca2f4d14c18014dc1c4f477907ea
+DIST iotop-c-1.19.tar.gz 115025 BLAKE2B 0b45a73afc5dd160692fa1a3d028afff2b4b242a008470679a669182baa56b133f5fd26f9cb3ed20ebfe18b7fdeba9ca98a7801299c8c9b8d776a58fed2725d2 SHA512 489ddd67eb4e9159058c94f614534290b302abd5af8b424f6c42df20f21362c60dc30e7fd0bac883b8bf032e72843b4b82dbfb77b670258728ef0fa9dbb7dfa3
diff --git a/sys-process/iotop-c/iotop-c-1.19.ebuild b/sys-process/iotop-c/iotop-c-1.19.ebuild
new file mode 100644
index 000000000000..b6d52c5d05fa
--- /dev/null
+++ b/sys-process/iotop-c/iotop-c-1.19.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps linux-info toolchain-funcs
+
+DESCRIPTION="top utility for IO (C port)"
+HOMEPAGE="https://github.com/Tomas-M/iotop"
+SRC_URI="https://github.com/Tomas-M/iotop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/iotop-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/ncurses:=
+ !sys-process/iotop"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+
+FILECAPS=(
+ cap_net_admin=eip usr/bin/iotop
+)
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)" NO_FLTO=1
+}
+
+src_install() {
+ dobin iotop
+ dodoc README.md
+ doman iotop.8
+}