summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-02-28 12:08:58 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-02-28 12:50:54 +0100
commitc226b6268a7b864085001ede99dbaff1dfc22634 (patch)
tree05ef0106457b33896b73be85653ddfcc9385e27d /sys-libs/tdb/tdb-1.3.15.ebuild
parentsys-libs/tdb: Bump to version 1.3.18 (diff)
downloadgentoo-c226b6268a7b864085001ede99dbaff1dfc22634.tar.gz
gentoo-c226b6268a7b864085001ede99dbaff1dfc22634.tar.bz2
gentoo-c226b6268a7b864085001ede99dbaff1dfc22634.zip
sys-libs/tdb: Removed old.
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/tdb/tdb-1.3.15.ebuild')
-rw-r--r--sys-libs/tdb/tdb-1.3.15.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/sys-libs/tdb/tdb-1.3.15.ebuild b/sys-libs/tdb/tdb-1.3.15.ebuild
deleted file mode 100644
index 006d6147deb6..000000000000
--- a/sys-libs/tdb/tdb-1.3.15.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads"
-
-inherit waf-utils multilib-minimal python-single-r1
-
-DESCRIPTION="A simple database API"
-HOMEPAGE="http://tdb.samba.org/"
-SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="python"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="
- ${RDEPEND}
- ${PYTHON_DEPS}
- app-text/docbook-xml-dtd:4.2"
-
-WAF_BINARY="${S}/buildtools/bin/waf"
-
-src_prepare() {
- default
- python_fix_shebang .
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- local extra_opts=()
- if ! multilib_is_native_abi || ! use python; then
- extra_opts+=( --disable-python )
- fi
-
- waf-utils_src_configure \
- "${extra_opts[@]}"
-}
-
-multilib_src_compile() {
- # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
- unset MAKEOPTS
- waf-utils_src_compile
-}
-
-multilib_src_test() {
- # the default src_test runs 'make test' and 'make check', letting
- # the tests fail occasionally (reason: unknown)
- emake check
-}
-
-multilib_src_install() {
- waf-utils_src_install
-}