summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2020-03-23 09:01:44 +0100
committerAgostino Sarubbo <ago@gentoo.org>2020-03-23 09:01:44 +0100
commitdf5e33226b5e3920b60387bfba9c6fa2f1b54bd9 (patch)
tree4683d2daa88b2ed2652c2bca63c5a6d197477458 /sys-kernel
parentmail-mta/postfix: remove old (diff)
downloadgentoo-df5e33226b5e3920b60387bfba9c6fa2f1b54bd9.tar.gz
gentoo-df5e33226b5e3920b60387bfba9c6fa2f1b54bd9.tar.bz2
gentoo-df5e33226b5e3920b60387bfba9c6fa2f1b54bd9.zip
sys-kernel/git-sources: Automated version bump to 5.6_rc7.
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.6_rc7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index b1efd8416fd8..f2f528b6a3be 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-5.6-rc3.patch 41366122 BLAKE2B 73f606aa9e24d7e0b4030f883007c0ee40810a
DIST patch-5.6-rc4.patch 41609569 BLAKE2B 1bcd1a93270b59224459c24a9808b84d872713c239f82a0c4b0aba71e9856b12598764a5c14ca410365e7d6461808f4d7a677e57e3423c910b5f1118edc6ea0c SHA512 46f9f16855065e1bd090b3520f7b7e55bdeab2ddf12b931d3b78e3e00872a070cb313dd7c25eb7631e34bd6bfeedefacca84f34927a64ae34c5251a8194182aa
DIST patch-5.6-rc5.patch 41919911 BLAKE2B 75da7c84962beed37bde19f7f74628096e81440e804cda47eb9446e36ba2499820283c88e0b2bb6404873d0429ab54fa3f3669a2bcd48de89921d0126ba82881 SHA512 e920816f968fbc7a6b5d7bbfe809fec49517b8435af870a1d7aa0cf07d8715122865d6ad84c1c35e28ad275d2ed7790774e4e39a197b850f6b041fb8b36b2c66
DIST patch-5.6-rc6.patch 42196466 BLAKE2B 1173598022b423e6c40f2ba97f974d7615f6097e8910ffc7985ea9e5fcf7659ba3af5ec240c2160108439cc76acbdc015cbfef67e863e0135e910663a047c6c6 SHA512 61ed2bd081fa7bd6154d38ab82bddb477d9c8b5eed2b1ef94e50dedf0116f3dab38a272b8a838aca4ea9752bc910f59ab16e48d2e278d3bd3126ca541f662844
+DIST patch-5.6-rc7.patch 42296845 BLAKE2B ac79d3dd7760df6acad0cc1d73a45cf92e1a98f61e91dae3405f293e47e1f18a71ef7222f8d4900382c2dca03422a92551aa1780c6114c577b9865f0ac8ce287 SHA512 c91b43f0841bdbfac36d4cce4b110134e88fbd973ff397d90c0be3133b947fd61afb50d82a5b884fde2d6549664690b88d129ee39d28ab39f8c76e8a98e92f30
diff --git a/sys-kernel/git-sources/git-sources-5.6_rc7.ebuild b/sys-kernel/git-sources/git-sources-5.6_rc7.ebuild
new file mode 100644
index 000000000000..4b09cc629ca9
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.6_rc7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.5"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}