summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-01-18 16:53:57 -0500
committerSam James <sam@gentoo.org>2024-01-24 06:54:38 +0000
commitb11c7460abd9916be76f8831466d5cc63bd079bf (patch)
treeeea32f4dc7398f6abd3224c597c4090f67e4b98d /sys-fs
parentdev-libs/icu: migrate checking for enabled lto, to tc-is-lto (diff)
downloadgentoo-b11c7460abd9916be76f8831466d5cc63bd079bf.tar.gz
gentoo-b11c7460abd9916be76f8831466d5cc63bd079bf.tar.bz2
gentoo-b11c7460abd9916be76f8831466d5cc63bd079bf.zip
sys-fs/xfsprogs: migrate checking for enabled lto, to tc-is-lto
This toolchain func was recently added, and is a lot more reliable than get-flagq, for example if the active flags contain `-flto -fno-lto` then tc-is-lto gets it correct. We would rather use this wherever possible. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xfsprogs/xfsprogs-6.3.0.ebuild6
-rw-r--r--sys-fs/xfsprogs/xfsprogs-6.4.0.ebuild6
-rw-r--r--sys-fs/xfsprogs/xfsprogs-6.5.0.ebuild6
3 files changed, 9 insertions, 9 deletions
diff --git a/sys-fs/xfsprogs/xfsprogs-6.3.0.ebuild b/sys-fs/xfsprogs/xfsprogs-6.3.0.ebuild
index 412d486c3314..b59bbeb5ee65 100644
--- a/sys-fs/xfsprogs/xfsprogs-6.3.0.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-6.3.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit flag-o-matic systemd usr-ldscript
+inherit flag-o-matic systemd usr-ldscript toolchain-funcs
DESCRIPTION="XFS filesystem utilities"
HOMEPAGE="https://xfs.wiki.kernel.org/ https://git.kernel.org/pub/scm/fs/xfs/xfsprogs-dev.git/"
@@ -75,7 +75,7 @@ src_configure() {
$(use_enable libedit editline)
)
- if is-flagq -flto ; then
+ if tc-is-lto ; then
myconf+=( --enable-lto )
else
myconf+=( --disable-lto )
diff --git a/sys-fs/xfsprogs/xfsprogs-6.4.0.ebuild b/sys-fs/xfsprogs/xfsprogs-6.4.0.ebuild
index afc21c0b6d8c..5ee0fb214a0e 100644
--- a/sys-fs/xfsprogs/xfsprogs-6.4.0.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-6.4.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit flag-o-matic systemd usr-ldscript
+inherit flag-o-matic systemd usr-ldscript toolchain-funcs
DESCRIPTION="XFS filesystem utilities"
HOMEPAGE="https://xfs.wiki.kernel.org/ https://git.kernel.org/pub/scm/fs/xfs/xfsprogs-dev.git/"
@@ -76,7 +76,7 @@ src_configure() {
$(use_enable libedit editline)
)
- if is-flagq -flto ; then
+ if tc-is-lto ; then
myconf+=( --enable-lto )
else
myconf+=( --disable-lto )
diff --git a/sys-fs/xfsprogs/xfsprogs-6.5.0.ebuild b/sys-fs/xfsprogs/xfsprogs-6.5.0.ebuild
index ab3847406679..a450486a8f38 100644
--- a/sys-fs/xfsprogs/xfsprogs-6.5.0.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-6.5.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit flag-o-matic systemd udev usr-ldscript
+inherit flag-o-matic systemd udev usr-ldscript toolchain-funcs
DESCRIPTION="XFS filesystem utilities"
HOMEPAGE="https://xfs.wiki.kernel.org/ https://git.kernel.org/pub/scm/fs/xfs/xfsprogs-dev.git/"
@@ -77,7 +77,7 @@ src_configure() {
$(use_enable libedit editline)
)
- if is-flagq -flto ; then
+ if tc-is-lto ; then
myconf+=( --enable-lto )
else
myconf+=( --disable-lto )