summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <git@xen0n.name>2022-01-11 12:46:01 +0800
committerFlorian Schmaus <flow@gentoo.org>2022-01-11 08:52:15 +0100
commitaff01743f50e8539f06414c6d53e28f9375932a3 (patch)
treef02bc96d2bfa6cd8131fac0fc7b8d267302e4868 /sys-fs/erofs-utils
parentapp-misc/ytree: remove 2.03 (diff)
downloadgentoo-aff01743f50e8539f06414c6d53e28f9375932a3.tar.gz
gentoo-aff01743f50e8539f06414c6d53e28f9375932a3.tar.bz2
gentoo-aff01743f50e8539f06414c6d53e28f9375932a3.zip
sys-fs/erofs-utils: bump to 1.4
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: WANG Xuerui <git@xen0n.name> Closes: https://github.com/gentoo/gentoo/pull/23734 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-fs/erofs-utils')
-rw-r--r--sys-fs/erofs-utils/Manifest1
-rw-r--r--sys-fs/erofs-utils/erofs-utils-1.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-fs/erofs-utils/Manifest b/sys-fs/erofs-utils/Manifest
index 80561cc1fd72..c546997af5cd 100644
--- a/sys-fs/erofs-utils/Manifest
+++ b/sys-fs/erofs-utils/Manifest
@@ -1 +1,2 @@
DIST erofs-utils-1.3.tar.gz 66135 BLAKE2B 1051cf387d059d71b91e0a940c86b819593902606ae4665a7801e9597dd72987385bee997d2d63b186c493557ee22118aff23161e48e25ee8f4859f9f6e46f14 SHA512 6ddd8402dab80b0375b012ed51ff02b40cbeca9a4a1ba250b14ec6aeb97317ab575e315e9d4dc77ed1d7826c202396d9c0775917106ecbd7b4048168aca0fa6c
+DIST erofs-utils-1.4.tar.gz 93979 BLAKE2B aef1dca8cb95e6104d73a84590319d3c55aba1a4ef5dbdbf470662cb86ee1b66a5707dc1c453470115ec6f2bf1246ee4b6b28aa1cb83b4cb9c8eed45e88668d4 SHA512 ab95d6a7b2d278ee443d1e378c62354db66ce7ab5ce03b3a8d9004cf498c4e43e3e8ced6524444d2ea4871c4db0195489f033180c8a2082c2cba69c46c09692f
diff --git a/sys-fs/erofs-utils/erofs-utils-1.4.ebuild b/sys-fs/erofs-utils/erofs-utils-1.4.ebuild
new file mode 100644
index 000000000000..1682bcdfb6d0
--- /dev/null
+++ b/sys-fs/erofs-utils/erofs-utils-1.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Userspace tools for EROFS"
+HOMEPAGE="https://git.kernel.org/pub/scm/linux/kernel/git/xiang/erofs-utils.git"
+LICENSE="GPL-2+"
+
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/xiang/${PN}.git/snapshot/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+SLOT="0"
+IUSE="fuse +lz4 selinux +uuid"
+
+RDEPEND="
+ fuse? ( sys-fs/fuse:0 )
+ lz4? ( app-arch/lz4:0= )
+ selinux? ( sys-libs/libselinux:0= )
+ uuid? ( sys-apps/util-linux )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # This package asks for MicroLZMA support, which is not included in any
+ # released version of xz-utils at the moment, so disable lzma until a new
+ # xz-utils is packaged.
+ econf \
+ $(use_enable fuse) \
+ $(use_enable lz4) \
+ --disable-lzma \
+ $(use_with selinux) \
+ $(use_with uuid)
+}