summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-11-21 22:43:04 +0100
committerSam James <sam@gentoo.org>2024-11-23 09:51:22 +0000
commitf0aa3f52546b99ab498a0233dd323e73f82559c0 (patch)
tree07b30f2761c4e0623fe57ff2f73527189a90ae73 /sys-fs/compsize
parentdev-python/cachecontrol: Remove old (diff)
downloadgentoo-f0aa3f52546b99ab498a0233dd323e73f82559c0.tar.gz
gentoo-f0aa3f52546b99ab498a0233dd323e73f82559c0.tar.bz2
gentoo-f0aa3f52546b99ab498a0233dd323e73f82559c0.zip
sys-fs/compsize: fix build with btrfs-progs >= 6.10.1
Closes: https://bugs.gentoo.org/938025 Signed-off-by: David Roman <davidroman96@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/compsize')
-rw-r--r--sys-fs/compsize/compsize-1.5.ebuild2
-rw-r--r--sys-fs/compsize/files/compsize-1.5-btrfs-progs.patch35
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-fs/compsize/compsize-1.5.ebuild b/sys-fs/compsize/compsize-1.5.ebuild
index 2f5223f474b9..49f2a0af1795 100644
--- a/sys-fs/compsize/compsize-1.5.ebuild
+++ b/sys-fs/compsize/compsize-1.5.ebuild
@@ -22,6 +22,8 @@ IUSE="debug"
DEPEND="sys-fs/btrfs-progs"
+PATCHES=( "${FILESDIR}/${P}-btrfs-progs.patch" )
+
src_prepare() {
default
# Don't try to install a gzipped manfile during emake install
diff --git a/sys-fs/compsize/files/compsize-1.5-btrfs-progs.patch b/sys-fs/compsize/files/compsize-1.5-btrfs-progs.patch
new file mode 100644
index 000000000000..3d2d75e370c0
--- /dev/null
+++ b/sys-fs/compsize/files/compsize-1.5-btrfs-progs.patch
@@ -0,0 +1,35 @@
+diff --git a/compsize.c b/compsize.c
+index 42ec304..0f533e5 100644
+--- a/compsize.c
++++ b/compsize.c
+@@ -5,12 +5,14 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <dirent.h>
++#include "kerncompat.h"
+ #include <btrfs/ioctl.h>
+ #include <btrfs/ctree.h>
+ #include <stdarg.h>
+ #include <stdlib.h>
+ #include <sys/ioctl.h>
+ #include <inttypes.h>
++#include <errno.h>
+ #include <linux/limits.h>
+ #include <getopt.h>
+ #include <signal.h>
+diff --git a/radix-tree.h b/radix-tree.h
+index bf96d83..d99ea7e 100644
+--- a/radix-tree.h
++++ b/radix-tree.h
+@@ -37,11 +37,7 @@
+ #ifndef _LINUX_RADIX_TREE_H
+ #define _LINUX_RADIX_TREE_H
+
+-#if BTRFS_FLAT_INCLUDES
+ #include "kerncompat.h"
+-#else
+-#include <btrfs/kerncompat.h>
+-#endif /* BTRFS_FLAT_INCLUDES */
+
+ #define RADIX_TREE_MAX_TAGS 2
+