summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-06 19:21:32 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-11-12 10:40:33 +0200
commit1fce2198adf40467499943f1542f557e80d85278 (patch)
treeaff9a57d2481acfcbeecfd680e0ca4bcc75c0972 /sys-fs/clamfs
parentnet-misc/seafile-client: version bump to 7.0.10 (diff)
downloadgentoo-1fce2198adf40467499943f1542f557e80d85278.tar.gz
gentoo-1fce2198adf40467499943f1542f557e80d85278.tar.bz2
gentoo-1fce2198adf40467499943f1542f557e80d85278.zip
sys-fs/clamfs: bump to 1.2.0
Closes: https://bugs.gentoo.org/732250 Closes: https://bugs.gentoo.org/737492 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-fs/clamfs')
-rw-r--r--sys-fs/clamfs/Manifest1
-rw-r--r--sys-fs/clamfs/clamfs-1.2.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-fs/clamfs/Manifest b/sys-fs/clamfs/Manifest
index 60f4aefc97cd..3589b07c38c4 100644
--- a/sys-fs/clamfs/Manifest
+++ b/sys-fs/clamfs/Manifest
@@ -1 +1,2 @@
DIST clamfs-1.0.1.tar.gz 142386 BLAKE2B d4333ddebae3aec1ffa36cd5db361b07daa4007c75e6f6e7e3c296f99573bde5ac77722b7af95fe194fd2ba0d56550a608911235da6cc7e9c25359af6554fcbd SHA512 8a9912c068c178049e8538da729635af1372e8ad1f7bc0e14cc7506208d15a4c1fdab7cf229dd683a3245168c627a3d994ec5b24bca5f12efc9ff638040e3258
+DIST clamfs-1.2.0.tar.gz 196903 BLAKE2B aa84e3a35714a2638d9569b6bb77f5da5c34f962d7baff0e5b08bbd7a56f1d1624936a5054b1a99d5593dc20412e55f36ab732fb84326f40c0614f084698618f SHA512 72a8625c18f520258075cb0310d14974e15f7f0cd628ca968317adac778fd8db26fa28bd72d954f2c21e6c41c32a38a5fbfa8be3918f9e0314d1d7f1da2cc626
diff --git a/sys-fs/clamfs/clamfs-1.2.0.ebuild b/sys-fs/clamfs/clamfs-1.2.0.ebuild
new file mode 100644
index 000000000000..af8952ff74bc
--- /dev/null
+++ b/sys-fs/clamfs/clamfs-1.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools linux-info
+
+DESCRIPTION="A FUSE-based user-space file system with on-access anti-virus file scanning"
+HOMEPAGE="https://github.com/burghardt/clamfs"
+SRC_URI="https://github.com/burghardt/clamfs/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-libs/boost-1.33
+ dev-libs/poco
+ dev-libs/rlog
+ sys-fs/fuse:3"
+RDEPEND="${DEPEND}
+ app-antivirus/clamav"
+
+CONFIG_CHECK="~FUSE_FS"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ insinto /etc/clamfs
+ doins doc/clamfs.xml
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}