summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuta Satoh <nigoro.dev@gmail.com>2016-10-11 21:37:39 +0900
committerAlexis Ballier <aballier@gentoo.org>2016-10-11 16:47:48 +0200
commite1bd456fcf9272cfdeaf542618c6b1f3ce3d1118 (patch)
tree6eb8e704f2281853b01e1abcd5770ad59d798e86 /sys-freebsd/boot0/files
parenteclass/freebsd.eclass: added FreeBSD 11.0 support. (diff)
downloadgentoo-e1bd456fcf9272cfdeaf542618c6b1f3ce3d1118.tar.gz
gentoo-e1bd456fcf9272cfdeaf542618c6b1f3ce3d1118.tar.bz2
gentoo-e1bd456fcf9272cfdeaf542618c6b1f3ce3d1118.zip
sys-freebsd: bump to 11.0
Diffstat (limited to 'sys-freebsd/boot0/files')
-rw-r--r--sys-freebsd/boot0/files/boot0-11.0-gcc46.patch14
-rw-r--r--sys-freebsd/boot0/files/boot0-11.0-uefi-support.patch21
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-freebsd/boot0/files/boot0-11.0-gcc46.patch b/sys-freebsd/boot0/files/boot0-11.0-gcc46.patch
new file mode 100644
index 000000000000..ec17d92b5790
--- /dev/null
+++ b/sys-freebsd/boot0/files/boot0-11.0-gcc46.patch
@@ -0,0 +1,14 @@
+diff --git a/sys/boot/i386/boot2/Makefile b/sys/boot/i386/boot2/Makefile
+index ead9ad1..af5e021 100644
+--- a/sys/boot/i386/boot2/Makefile
++++ b/sys/boot/i386/boot2/Makefile
+@@ -45,6 +45,9 @@ CFLAGS.gcc+= -Os \
+ .if ${COMPILER_TYPE} == "gcc" && ${COMPILER_VERSION} <= 40201
+ CFLAGS.gcc+= -mno-align-long-strings
+ .endif
++.if ${COMPILER_TYPE} == "gcc" && ${COMPILER_VERSION} >= 40600
++CFLAGS.gcc+= -fno-asynchronous-unwind-tables
++.endif
+
+ CFLAGS.clang+= -Oz ${CLANG_OPT_SMALL}
+
diff --git a/sys-freebsd/boot0/files/boot0-11.0-uefi-support.patch b/sys-freebsd/boot0/files/boot0-11.0-uefi-support.patch
new file mode 100644
index 000000000000..c7a69d62aa8b
--- /dev/null
+++ b/sys-freebsd/boot0/files/boot0-11.0-uefi-support.patch
@@ -0,0 +1,21 @@
+diff --git a/sys/boot/efi/Makefile b/sys/boot/efi/Makefile
+index 79ee9a9..f7789f1 100644
+--- a/sys/boot/efi/Makefile
++++ b/sys/boot/efi/Makefile
+@@ -4,7 +4,7 @@
+
+ # In-tree GCC does not support __attribute__((ms_abi)), but gcc newer
+ # than 4.5 supports it.
+-.if ${COMPILER_TYPE} != "gcc" || ${COMPILER_VERSION} >= 404500
++.if ${COMPILER_TYPE} != "gcc" || ${COMPILER_VERSION} >= 40500
+
+ .if ${MACHINE_CPUARCH} == "aarch64" || ${MACHINE_CPUARCH} == "arm"
+ .if ${MK_FDT} != "no"
+@@ -18,6 +18,6 @@ SUBDIR+= fdt
+ SUBDIR+= libefi loader boot1
+ .endif
+
+-.endif # ${COMPILER_TYPE} != "gcc" || ${COMPILER_VERSION} >= 404500
++.endif # ${COMPILER_TYPE} != "gcc" || ${COMPILER_VERSION} >= 40500
+
+ .include <bsd.subdir.mk>