summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-28 11:36:23 +0000
committerSam James <sam@gentoo.org>2024-10-28 11:38:18 +0000
commitf6da81d9f85e2223a469e043dc95fd6fc555409f (patch)
treed6208f79097b50cbd420344b1e6cbe3f6b22018e /sys-devel
parentgui-libs/egl-x11: quick workaround for clang (diff)
downloadgentoo-f6da81d9f85e2223a469e043dc95fd6fc555409f.tar.gz
gentoo-f6da81d9f85e2223a469e043dc95fd6fc555409f.tar.bz2
gentoo-f6da81d9f85e2223a469e043dc95fd6fc555409f.zip
sys-devel/mold: workaround linux-6.11 incompatibility
Don't write to existing files, instead replace them. This fixes (or works around) an incompatibility with linux-6.11. Bug: https://github.com/rui314/mold/issues/1361 Bug: https://bugs.gentoo.org/938659 Closes: https://bugs.gentoo.org/941070 Thanks-to: Jinghao Jia <jinghao7@illinois.edu> Thanks-to: ernsteiswuerfel <erhard_f@mailbox.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/mold/files/mold-2.34.1-linux-6.11.patch22
-rw-r--r--sys-devel/mold/mold-2.34.1-r1.ebuild107
-rw-r--r--sys-devel/mold/mold-9999.ebuild4
3 files changed, 133 insertions, 0 deletions
diff --git a/sys-devel/mold/files/mold-2.34.1-linux-6.11.patch b/sys-devel/mold/files/mold-2.34.1-linux-6.11.patch
new file mode 100644
index 000000000000..8540ec0cb246
--- /dev/null
+++ b/sys-devel/mold/files/mold-2.34.1-linux-6.11.patch
@@ -0,0 +1,22 @@
+https://lore.kernel.org/stable/CACKH++YAtEMYu2nTLUyfmxZoGO37fqogKMDkBpddmNaz5HE6ng@mail.gmail.com/T/#u
+https://github.com/rui314/mold/issues/1361
+https://bugs.gentoo.org/941070
+--- a/src/output-file-unix.cc
++++ b/src/output-file-unix.cc
+@@ -19,16 +19,6 @@ template <typename E>
+ static int
+ open_or_create_file(Context<E> &ctx, std::string path, std::string tmpfile,
+ int perm) {
+- // Reuse an existing file if exists and writable because on Linux,
+- // writing to an existing file is much faster than creating a fresh
+- // file and writing to it.
+- if (ctx.overwrite_output_file && rename(path.c_str(), tmpfile.c_str()) == 0) {
+- i64 fd = ::open(tmpfile.c_str(), O_RDWR | O_CREAT, perm);
+- if (fd != -1)
+- return fd;
+- unlink(tmpfile.c_str());
+- }
+-
+ i64 fd = ::open(tmpfile.c_str(), O_RDWR | O_CREAT, perm);
+ if (fd == -1)
+ Fatal(ctx) << "cannot open " << tmpfile << ": " << errno_string();
diff --git a/sys-devel/mold/mold-2.34.1-r1.ebuild b/sys-devel/mold/mold-2.34.1-r1.ebuild
new file mode 100644
index 000000000000..e9cd29a7fe47
--- /dev/null
+++ b/sys-devel/mold/mold-2.34.1-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic toolchain-funcs
+
+DESCRIPTION="A Modern Linker"
+HOMEPAGE="https://github.com/rui314/mold"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/rui314/mold.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/rui314/mold/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ # -alpha: https://github.com/rui314/mold/commit/3711ddb95e23c12991f6b8c7bfeba4f1421d19d4
+ KEYWORDS="-alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~riscv ~sparc ~x86"
+fi
+
+# mold (MIT)
+# - xxhash (BSD-2)
+# - siphash ( MIT CC0-1.0 )
+LICENSE="MIT BSD-2 CC0-1.0"
+SLOT="0"
+IUSE="debug"
+
+RDEPEND="
+ app-arch/zstd:=
+ >=dev-cpp/tbb-2021.7.0-r1:=
+ dev-libs/blake3:=
+ sys-libs/zlib
+ !kernel_Darwin? (
+ >=dev-libs/mimalloc-2:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.34.1-linux-6.11.patch
+)
+
+pkg_pretend() {
+ # Requires a c++20 compiler, see #831473
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if tc-is-gcc && [[ $(gcc-major-version) -lt 10 ]]; then
+ die "${PN} needs at least gcc 10"
+ elif tc-is-clang && [[ $(clang-major-version) -lt 12 ]]; then
+ die "${PN} needs at least clang 12"
+ fi
+ fi
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Needs unpackaged dwarfdump
+ rm test/{{dead,compress}-debug-sections,compressed-debug-info}.sh || die
+
+ # Heavy tests, need qemu
+ rm test/gdb-index-{compress-output,dwarf{2,3,4,5}}.sh || die
+ rm test/lto-{archive,dso,gcc,llvm,version-script}.sh || die
+
+ # Sandbox sadness
+ rm test/run.sh || die
+ sed -i 's|`pwd`/mold-wrapper.so|"& ${LD_PRELOAD}"|' \
+ test/mold-wrapper{,2}.sh || die
+
+ # static-pie tests require glibc built with static-pie support
+ if ! has_version -d 'sys-libs/glibc[static-pie(+)]'; then
+ rm test/{,ifunc-}static-pie.sh || die
+ fi
+}
+
+src_configure() {
+ use debug || append-cppflags "-DNDEBUG"
+
+ local mycmakeargs=(
+ -DMOLD_ENABLE_QEMU_TESTS=OFF
+ -DMOLD_LTO=OFF # Should be up to the user to decide this with CXXFLAGS.
+ -DMOLD_USE_MIMALLOC=$(usex !kernel_Darwin)
+ -DMOLD_USE_SYSTEM_MIMALLOC=ON
+ -DMOLD_USE_SYSTEM_TBB=ON
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ dobin "${BUILD_DIR}"/${PN}
+
+ # https://bugs.gentoo.org/872773
+ insinto /usr/$(get_libdir)/mold
+ doins "${BUILD_DIR}"/${PN}-wrapper.so
+
+ dodoc docs/{design,execstack}.md
+ doman docs/${PN}.1
+
+ dosym ${PN} /usr/bin/ld.${PN}
+ dosym ${PN} /usr/bin/ld64.${PN}
+ dosym -r /usr/bin/${PN} /usr/libexec/${PN}/ld
+}
+
+src_test() {
+ export TEST_CC="$(tc-getCC)" \
+ TEST_GCC="$(tc-getCC)" \
+ TEST_CXX="$(tc-getCXX)" \
+ TEST_GXX="$(tc-getCXX)"
+ cmake_src_test
+}
diff --git a/sys-devel/mold/mold-9999.ebuild b/sys-devel/mold/mold-9999.ebuild
index 456f654912e4..e9cd29a7fe47 100644
--- a/sys-devel/mold/mold-9999.ebuild
+++ b/sys-devel/mold/mold-9999.ebuild
@@ -34,6 +34,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.34.1-linux-6.11.patch
+)
+
pkg_pretend() {
# Requires a c++20 compiler, see #831473
if [[ ${MERGE_TYPE} != binary ]]; then