summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-11-20 02:24:34 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-11-20 02:27:58 +0100
commitb68ed1d0de974f2bb97f526db4619b575b233d12 (patch)
tree89b2a96aa83e367dfdcdb2cb7d9d3a4ab9fbd25b /sys-devel
parentx11-misc/xscreensaver: update gdk-pixbuf dep (diff)
downloadgentoo-b68ed1d0de974f2bb97f526db4619b575b233d12.tar.gz
gentoo-b68ed1d0de974f2bb97f526db4619b575b233d12.tar.bz2
gentoo-b68ed1d0de974f2bb97f526db4619b575b233d12.zip
sys-devel/automake: fix tests
Closes: https://bugs.gentoo.org/715040 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/automake/automake-1.16.2-r1.ebuild (renamed from sys-devel/automake/automake-1.16.3.ebuild)4
-rw-r--r--sys-devel/automake/automake-1.16.3-r1.ebuild (renamed from sys-devel/automake/automake-1.16.2.ebuild)3
-rw-r--r--sys-devel/automake/files/automake-1.16.2-fix-instmany-python.sh-test.patch26
-rw-r--r--sys-devel/automake/files/automake-1.16.2-fix-py-compile-basedir.sh-test.patch26
-rw-r--r--sys-devel/automake/files/automake-1.16.2-skip-tags-lisp-space-without-etags.patch23
5 files changed, 80 insertions, 2 deletions
diff --git a/sys-devel/automake/automake-1.16.3.ebuild b/sys-devel/automake/automake-1.16.2-r1.ebuild
index fc05add3e373..c815bac5a5d4 100644
--- a/sys-devel/automake/automake-1.16.3.ebuild
+++ b/sys-devel/automake/automake-1.16.2-r1.ebuild
@@ -48,8 +48,10 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/automake-1.16.2-py3-compile.patch
+ "${FILESDIR}"/automake-1.16.2-fix-instmany-python.sh-test.patch
+ "${FILESDIR}"/automake-1.16.2-fix-py-compile-basedir.sh-test.patch
+ "${FILESDIR}"/automake-1.16.2-skip-tags-lisp-space-without-etags.patch
)
-# All patches have been submitted upstream.
pkg_setup() {
use test && python-any-r1_pkg_setup
diff --git a/sys-devel/automake/automake-1.16.2.ebuild b/sys-devel/automake/automake-1.16.3-r1.ebuild
index fc05add3e373..361141a285ab 100644
--- a/sys-devel/automake/automake-1.16.2.ebuild
+++ b/sys-devel/automake/automake-1.16.3-r1.ebuild
@@ -48,8 +48,9 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/automake-1.16.2-py3-compile.patch
+ "${FILESDIR}"/automake-1.16.2-fix-instmany-python.sh-test.patch
+ "${FILESDIR}"/automake-1.16.2-fix-py-compile-basedir.sh-test.patch
)
-# All patches have been submitted upstream.
pkg_setup() {
use test && python-any-r1_pkg_setup
diff --git a/sys-devel/automake/files/automake-1.16.2-fix-instmany-python.sh-test.patch b/sys-devel/automake/files/automake-1.16.2-fix-instmany-python.sh-test.patch
new file mode 100644
index 000000000000..5cddb4cfb83f
--- /dev/null
+++ b/sys-devel/automake/files/automake-1.16.2-fix-instmany-python.sh-test.patch
@@ -0,0 +1,26 @@
+From 50daac4f15d207b6b69011b9cdde62b56c1c8b10 Mon Sep 17 00:00:00 2001
+From: Thomas Deutschmann <whissi@gentoo.org>
+Date: Fri, 20 Nov 2020 02:17:31 +0100
+Subject: [PATCH 2/2] tests: fix instmany-python.sh: increase limit
+
+Still failing with 4500 on Gentoo. Passing with 7000...
+---
+ t/instmany-python.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/t/instmany-python.sh b/t/instmany-python.sh
+index dce3594b5..1c482520d 100644
+--- a/t/instmany-python.sh
++++ b/t/instmany-python.sh
+@@ -21,7 +21,7 @@
+ required='python'
+ . test-init.sh
+
+-limit=4500
++limit=7000
+ subdir=long_subdir_name_with_many_characters
+ nfiles=81
+ list=$(seq_ 1 $nfiles)
+--
+2.29.2
+
diff --git a/sys-devel/automake/files/automake-1.16.2-fix-py-compile-basedir.sh-test.patch b/sys-devel/automake/files/automake-1.16.2-fix-py-compile-basedir.sh-test.patch
new file mode 100644
index 000000000000..f49dd253c2d6
--- /dev/null
+++ b/sys-devel/automake/files/automake-1.16.2-fix-py-compile-basedir.sh-test.patch
@@ -0,0 +1,26 @@
+From e3db5b8038a902501a354b6921dcebcb4180f50a Mon Sep 17 00:00:00 2001
+From: Thomas Deutschmann <whissi@gentoo.org>
+Date: Fri, 20 Nov 2020 02:13:56 +0100
+Subject: [PATCH 1/2] tests: fix py-compile-basedir.sh: add missing test call
+
+Fixes: b279a0d46 ("tests: in python tests, do not require .pyo files (for python3)")
+---
+ t/py-compile-basedir.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/t/py-compile-basedir.sh b/t/py-compile-basedir.sh
+index 13a22ff1d..1a16ee2d7 100644
+--- a/t/py-compile-basedir.sh
++++ b/t/py-compile-basedir.sh
+@@ -43,7 +43,7 @@ for d in foo foo/bar "$(pwd)/foo" . .. ../foo ''; do
+ py_installed "$d2/sub/$f.pyc"
+ files=$(find "$d2" | grep '\.py[co]$')
+ # with new-enough Python3, there are six files.
+- test $(echo "$files" | wc -l) -eq 4 || $(echo "$files" | wc -l) -eq 6
++ test $(echo "$files" | wc -l) -eq 4 || test $(echo "$files" | wc -l) -eq 6
+ case $d2 in
+ .|..) rm -f $files;;
+ *) rm -rf "$d2";;
+--
+2.29.2
+
diff --git a/sys-devel/automake/files/automake-1.16.2-skip-tags-lisp-space-without-etags.patch b/sys-devel/automake/files/automake-1.16.2-skip-tags-lisp-space-without-etags.patch
new file mode 100644
index 000000000000..70ca8f783c3e
--- /dev/null
+++ b/sys-devel/automake/files/automake-1.16.2-skip-tags-lisp-space-without-etags.patch
@@ -0,0 +1,23 @@
+From 77d39959511295f5a30332d5d03f0a6956bd9460 Mon Sep 17 00:00:00 2001
+From: Karl Berry <karl@freefriends.org>
+Date: Tue, 24 Mar 2020 18:30:18 -0700
+Subject: [PATCH] tests: require etags for tags-lisp-space test.
+
+* t/tags-lisp-space.sh (required): set to etags.
+---
+ t/tags-lisp-space.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/t/tags-lisp-space.sh b/t/tags-lisp-space.sh
+index d0a940ba3..44312b0b7 100755
+--- a/t/tags-lisp-space.sh
++++ b/t/tags-lisp-space.sh
+@@ -18,7 +18,7 @@
+ # if there are CONFIG_HEADERS.
+ # See automake bug#38139.
+
+-required=''
++required=etags
+ . test-init.sh
+
+ # some AC_CONFIG_FILES header is needed to trigger the bug.