summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 12:09:36 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 12:53:11 +0100
commitb060a63ee02c38b2fa87212b3770c0d016bf3af7 (patch)
tree7ece9dabf8d25d95e18c38970ce4b98c92b5912c /sys-devel
parentMove {dev-libs/libclc → llvm-core/libclc} (diff)
downloadgentoo-b060a63ee02c38b2fa87212b3770c0d016bf3af7.tar.gz
gentoo-b060a63ee02c38b2fa87212b3770c0d016bf3af7.tar.bz2
gentoo-b060a63ee02c38b2fa87212b3770c0d016bf3af7.zip
Move sys-libs/llvm-libunwind → llvm-runtimes/libunwind
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-15.0.7-r10.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-16.0.6-r6.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-17.0.6-r10.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-17.0.6-r9.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-18.1.8-r3.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-19.1.4.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-19.1.5.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-20.0.0.9999.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-20.0.0_pre20241207.ebuild2
9 files changed, 9 insertions, 9 deletions
diff --git a/sys-devel/clang-common/clang-common-15.0.7-r10.ebuild b/sys-devel/clang-common/clang-common-15.0.7-r10.ebuild
index d724729a628b..863210b432e1 100644
--- a/sys-devel/clang-common/clang-common-15.0.7-r10.ebuild
+++ b/sys-devel/clang-common/clang-common-15.0.7-r10.ebuild
@@ -19,7 +19,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
sys-devel/clang-runtime:${PV}[compiler-rt]
- llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
+ llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
diff --git a/sys-devel/clang-common/clang-common-16.0.6-r6.ebuild b/sys-devel/clang-common/clang-common-16.0.6-r6.ebuild
index e6b8345426e7..3c2341b48f12 100644
--- a/sys-devel/clang-common/clang-common-16.0.6-r6.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.6-r6.ebuild
@@ -19,7 +19,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
- llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
+ llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
diff --git a/sys-devel/clang-common/clang-common-17.0.6-r10.ebuild b/sys-devel/clang-common/clang-common-17.0.6-r10.ebuild
index b7f5fcd8d0e0..4b4afea86e18 100644
--- a/sys-devel/clang-common/clang-common-17.0.6-r10.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.6-r10.ebuild
@@ -19,7 +19,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
- llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
+ llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
diff --git a/sys-devel/clang-common/clang-common-17.0.6-r9.ebuild b/sys-devel/clang-common/clang-common-17.0.6-r9.ebuild
index 5f634ac72ad7..406fb5e000ac 100644
--- a/sys-devel/clang-common/clang-common-17.0.6-r9.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.6-r9.ebuild
@@ -19,7 +19,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
- llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
+ llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
diff --git a/sys-devel/clang-common/clang-common-18.1.8-r3.ebuild b/sys-devel/clang-common/clang-common-18.1.8-r3.ebuild
index bd5543518470..d27470c98f00 100644
--- a/sys-devel/clang-common/clang-common-18.1.8-r3.ebuild
+++ b/sys-devel/clang-common/clang-common-18.1.8-r3.ebuild
@@ -19,7 +19,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
- llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
+ llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
diff --git a/sys-devel/clang-common/clang-common-19.1.4.ebuild b/sys-devel/clang-common/clang-common-19.1.4.ebuild
index ec4f3dbef5f3..30192b7fa601 100644
--- a/sys-devel/clang-common/clang-common-19.1.4.ebuild
+++ b/sys-devel/clang-common/clang-common-19.1.4.ebuild
@@ -19,7 +19,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
- llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
+ llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
diff --git a/sys-devel/clang-common/clang-common-19.1.5.ebuild b/sys-devel/clang-common/clang-common-19.1.5.ebuild
index d587000e70f7..5f4044001548 100644
--- a/sys-devel/clang-common/clang-common-19.1.5.ebuild
+++ b/sys-devel/clang-common/clang-common-19.1.5.ebuild
@@ -19,7 +19,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
- llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
+ llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
diff --git a/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild
index 0351c7b25564..b3216cd5a275 100644
--- a/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild
@@ -18,7 +18,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
- llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
+ llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )
diff --git a/sys-devel/clang-common/clang-common-20.0.0_pre20241207.ebuild b/sys-devel/clang-common/clang-common-20.0.0_pre20241207.ebuild
index 0351c7b25564..b3216cd5a275 100644
--- a/sys-devel/clang-common/clang-common-20.0.0_pre20241207.ebuild
+++ b/sys-devel/clang-common/clang-common-20.0.0_pre20241207.ebuild
@@ -18,7 +18,7 @@ IUSE="
PDEPEND="
default-compiler-rt? (
sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
- llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
+ llvm-libunwind? ( llvm-runtimes/libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
!default-compiler-rt? ( sys-devel/gcc )