summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-13 05:09:23 +0000
committerSam James <sam@gentoo.org>2022-12-13 05:09:23 +0000
commit46157aa6b7e7bd9f041e5ac61a4a218fc33280e4 (patch)
treeeb404c3f797ab8d642a47ffae1f64eb1bbe1d6ea /sys-devel
parentdev-perl/IO-Socket-SSL: drop 2.76.0, 2.77.0 (diff)
downloadgentoo-46157aa6b7e7bd9f041e5ac61a4a218fc33280e4.tar.gz
gentoo-46157aa6b7e7bd9f041e5ac61a4a218fc33280e4.tar.bz2
gentoo-46157aa6b7e7bd9f041e5ac61a4a218fc33280e4.zip
sys-devel/m4: fix tests w/ make 4.4
Test-only fix so no revbump. Closes: https://bugs.gentoo.org/879061 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/m4/files/m4-1.4.19-make-4.4-tests.patch38
-rw-r--r--sys-devel/m4/m4-1.4.19.ebuild1
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-devel/m4/files/m4-1.4.19-make-4.4-tests.patch b/sys-devel/m4/files/m4-1.4.19-make-4.4-tests.patch
new file mode 100644
index 000000000000..f7bc3f0e9b35
--- /dev/null
+++ b/sys-devel/m4/files/m4-1.4.19-make-4.4-tests.patch
@@ -0,0 +1,38 @@
+https://bugs.gentoo.org/879061
+
+https://savannah.gnu.org/bugs/index.php?63307 (make bug)
+https://savannah.gnu.org/support/?110767 (M4 bug)
+
+https://lists.gnu.org/archive/html/bug-m4/2022-11/msg00003.html
+https://savannah.gnu.org/support/download.php?file_id=53951
+
+From ed64def45d68b2af53f1d3d783cc98e9dbe2ff74 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex@linutronix.de>
+Date: Sat, 12 Nov 2022 15:18:41 +0100
+Subject: [PATCH] test-execute-main.c: set default handler for SIGPIPE in tests
+ 3 and 4
+
+make 4.4 sets this to SIG_IGN and the tests fail
+
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+--- a/tests/test-execute-main.c
++++ b/tests/test-execute-main.c
+@@ -132,6 +132,7 @@ main (int argc, char *argv[])
+ #if !(defined _WIN32 && !defined __CYGWIN__)
+ {
+ /* Check SIGPIPE handling with ignore_sigpipe = false. */
++ signal(SIGPIPE, SIG_DFL);
+ const char *prog_argv[3] = { prog_path, "3", NULL };
+ int termsig = 0x7DEADBEE;
+ int ret = execute (progname, prog_argv[0], prog_argv, NULL,
+@@ -145,6 +146,7 @@ main (int argc, char *argv[])
+ #if !(defined _WIN32 && !defined __CYGWIN__)
+ {
+ /* Check SIGPIPE handling with ignore_sigpipe = true. */
++ signal(SIGPIPE, SIG_DFL);
+ const char *prog_argv[3] = { prog_path, "4", NULL };
+ int termsig = 0x7DEADBEE;
+ int ret = execute (progname, prog_argv[0], prog_argv, NULL,
+--
+2.30.2
+
diff --git a/sys-devel/m4/m4-1.4.19.ebuild b/sys-devel/m4/m4-1.4.19.ebuild
index fcfe153e5958..fab597f0fcad 100644
--- a/sys-devel/m4/m4-1.4.19.ebuild
+++ b/sys-devel/m4/m4-1.4.19.ebuild
@@ -39,6 +39,7 @@ BDEPEND="app-arch/xz-utils
PATCHES=(
"${FILESDIR}"/ppc-musl.patch
"${FILESDIR}"/loong-fix-build.patch
+ "${FILESDIR}"/${PN}-1.4.19-make-4.4-tests.patch
"${WORKDIR}"/${P}-test-198-sysval-r1.patch
)