summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-12-31 01:44:53 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-31 01:45:14 -0500
commit5114947b64b4c7a15f713c636ea4b3031a04a3fa (patch)
treeb4e0e108dbe13a961040c787ea16812d8c0b9764 /sys-devel/gcc/gcc-4.9.3.ebuild
parentMerge remote-tracking branch 'remotes/CraigInches/Task-2.5.0' (diff)
downloadgentoo-5114947b64b4c7a15f713c636ea4b3031a04a3fa.tar.gz
gentoo-5114947b64b4c7a15f713c636ea4b3031a04a3fa.tar.bz2
gentoo-5114947b64b4c7a15f713c636ea4b3031a04a3fa.zip
sys-apps/gcc: restore 4.9.3
Previous clean up shouldn't have dropped this version as it's our current stable.
Diffstat (limited to 'sys-devel/gcc/gcc-4.9.3.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.9.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-4.9.3.ebuild b/sys-devel/gcc/gcc-4.9.3.ebuild
new file mode 100644
index 000000000000..5868123f46c2
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.9.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+PATCH_VER="1.4"
+UCLIBC_VER="1.0"
+
+# Hardened gcc 4 stuff
+PIE_VER="0.6.4"
+SPECS_VER="0.2.0"
+SPECS_GCC_VER="4.4.3"
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+PIE_GLIBC_STABLE="x86 amd64 mips ppc ppc64 arm ia64"
+PIE_UCLIBC_STABLE="x86 arm amd64 mips ppc ppc64"
+SSP_STABLE="amd64 x86 mips ppc ppc64 arm"
+# uclibc need tls and nptl support for SSP support
+# uclibc need to be >= 0.9.33
+SSP_UCLIBC_STABLE="x86 amd64 mips ppc ppc64 arm"
+#end Hardened stuff
+
+inherit eutils toolchain
+
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh ~sparc x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_prepare() {
+ if has_version '<sys-libs/glibc-2.12' ; then
+ ewarn "Your host glibc is too old; disabling automatic fortify."
+ ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
+ EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
+ fi
+
+ toolchain_src_prepare
+
+ use vanilla && return 0
+ #Use -r1 for newer piepatchet that use DRIVER_SELF_SPECS for the hardened specs.
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env-r1.patch
+}