summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2018-08-15 00:00:37 +0200
committerUltrabug <ultrabug@gentoo.org>2018-08-15 00:00:37 +0200
commitd4b40465b27860b99a65808e467fba687459caa0 (patch)
tree6f0246ff6657f2ac81f388b51e1d3e8cd6bbe3ee /sys-cluster/pacemaker
parentdev-libs/mongo-c-driver: bump to 1.12.0 (diff)
downloadgentoo-d4b40465b27860b99a65808e467fba687459caa0.tar.gz
gentoo-d4b40465b27860b99a65808e467fba687459caa0.tar.bz2
gentoo-d4b40465b27860b99a65808e467fba687459caa0.zip
sys-cluster/pacemaker: version bump
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'sys-cluster/pacemaker')
-rw-r--r--sys-cluster/pacemaker/Manifest1
-rw-r--r--sys-cluster/pacemaker/pacemaker-1.1.19.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/sys-cluster/pacemaker/Manifest b/sys-cluster/pacemaker/Manifest
index 6026aa42b4fb..d9410b999b28 100644
--- a/sys-cluster/pacemaker/Manifest
+++ b/sys-cluster/pacemaker/Manifest
@@ -1 +1,2 @@
DIST Pacemaker-1.1.16.tar.gz 4897772 BLAKE2B a6ea8b3e5f6ef776a67d8895a0361945c5bcd98ecd861c0fd8d8b3c474a6f14c816e1f36da1dccd429ab8d92c53a9dd071796968d5080d6a900518df200fafbd SHA512 967c860fab7b9e73dd8643e6d09083a2a1298a77d71c3b138187803c89153bee7219da13e6b94b20f2881b53ba7fc1c8584a43ff058a265e76708fd5dbccf534
+DIST Pacemaker-1.1.19.tar.gz 5369381 BLAKE2B 9134f014b4da61c01bb2533ad33201400335d9e722e064f5e838df851777cfd17115430bd4623b08b97330bfe98340091f06a98c06dd125761053e79f0375dd2 SHA512 c41403441a3ba7a4fb81b6c3e84d7eff5ee951e1040918597ea8462284c83dc6f572607d4903b1238c55757f1eca78132878a172da4e3b5db2dbfe0831c34548
diff --git a/sys-cluster/pacemaker/pacemaker-1.1.19.ebuild b/sys-cluster/pacemaker/pacemaker-1.1.19.ebuild
new file mode 100644
index 000000000000..d53ebabf7236
--- /dev/null
+++ b/sys-cluster/pacemaker/pacemaker-1.1.19.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils python-single-r1
+
+MY_PN="Pacemaker"
+MY_P=${MY_PN}-${PV/_/-}
+
+DESCRIPTION="Pacemaker CRM"
+HOMEPAGE="http://www.linux-ha.org/wiki/Pacemaker"
+SRC_URI="https://github.com/ClusterLabs/${PN}/archive/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+REQUIRED_USE="cman? ( !heartbeat )"
+IUSE="acl cman heartbeat smtp snmp static-libs"
+
+DEPEND="${PYTHON_DEPS}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ sys-cluster/cluster-glue
+ >=sys-cluster/libqb-0.14.0
+ sys-cluster/resource-agents
+ cman? ( sys-cluster/cman )
+ heartbeat? ( >=sys-cluster/heartbeat-3.0.0 )
+ !heartbeat? ( sys-cluster/corosync )
+ smtp? ( net-libs/libesmtp )
+ snmp? ( net-analyzer/net-snmp )
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S="${WORKDIR}/${PN}-${MY_P}"
+
+src_prepare() {
+ default
+ sed -i -e "s/ -ggdb//g" configure.ac || die
+ eautoreconf
+ python_fix_shebang .
+}
+
+src_configure() {
+ local myopts=""
+ if use heartbeat ; then
+ myopts="--without-corosync"
+ else
+ myopts="--with-ais"
+ fi
+ # appends lib to localstatedir automatically
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --localstatedir=/var \
+ --disable-dependency-tracking \
+ --disable-fatal-warnings \
+ $(use_with acl) \
+ $(use_with cman cs-quorum) \
+ $(use_with cman cman) \
+ $(use_with heartbeat) \
+ $(use_with smtp esmtp) \
+ $(use_with snmp) \
+ $(use_enable static-libs static) \
+ ${myopts}
+}
+
+src_install() {
+ default
+ rm -rf "${D}"/var/run "${D}"/etc/init.d
+ newinitd "${FILESDIR}/${PN}.initd" ${PN} || die
+ if has_version "<sys-cluster/corosync-2.0"; then
+ insinto /etc/corosync/service.d
+ newins "${FILESDIR}/${PN}.service" ${PN} || die
+ fi
+}