summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-04-27 14:40:13 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-04-27 14:40:30 -0500
commit3e9a638ecfb868f88e5917996ff2e33c824f2c27 (patch)
tree517ae91aa64f81af202f7d6843d76ea4c6952eeb /sys-cluster/nomad
parentdev-python/requests: Bump to 2.29.0 (diff)
downloadgentoo-3e9a638ecfb868f88e5917996ff2e33c824f2c27.tar.gz
gentoo-3e9a638ecfb868f88e5917996ff2e33c824f2c27.tar.bz2
gentoo-3e9a638ecfb868f88e5917996ff2e33c824f2c27.zip
sys-cluster/nomad: add 1.5.3
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster/nomad')
-rw-r--r--sys-cluster/nomad/Manifest2
-rw-r--r--sys-cluster/nomad/nomad-1.5.3.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-cluster/nomad/Manifest b/sys-cluster/nomad/Manifest
index ae51c63496b8..3dbb90366f1d 100644
--- a/sys-cluster/nomad/Manifest
+++ b/sys-cluster/nomad/Manifest
@@ -1,2 +1,4 @@
DIST nomad-1.4.3-deps.tar.xz 380318008 BLAKE2B 76dcb628d70d94019870e8837770f06b270c12f06f29bccc8394992c0bb04856e58bfcb5cbcc439b9401ad9433935d7480db5a7201d3b120d6374418fb347f67 SHA512 d634f3400d48e452ceeac43754bda5970b5bfe41a3478e50752cc3b93fcaef881b8781920647417bd16d780fea0387769c946680308f0f926520cc7f5ceb649c
DIST nomad-1.4.3.tar.gz 23243041 BLAKE2B dec5cb10993b45da906e98446531679543befd820b5dde226a4ea12e817408330cc80806e5b85c54d968fe110249bc266bb9426cc6f59e64c0c0ce78a4e5b884 SHA512 abc4b6b62e5693d7efd80a29726b21544fe3c8b03099f5cb2e1aa6707f512ea6f744c250996bc8d3f3f70bb4eaf6177d7640c8decb503800bee5397d9c0b4140
+DIST nomad-1.5.3-deps.tar.xz 413102012 BLAKE2B 038953b122a194c56c5c9436d76099022da18dd6b5b639d0b2fcee321a24c23bc6deee63e27638ab79996728a83f9ba9b8d2151265ed6fbbe613d2402c84c88b SHA512 0b483b66fa1ed8f1b38ae77db3aef008341416ffc24abb29121560634bb31a7282e26333bb8330386049bea60eb8ae3ef58eab37785eb2446e9d55029b6ecb46
+DIST nomad-1.5.3.tar.gz 23976676 BLAKE2B 4d237e2610b3c2e9c887d115474b628ba81814fb1c2e89e387b63329072817c9f3768557d33e98f199e9f16e08cc81797d31a7570e18fa0d6c450aa6e0799969 SHA512 c058c367cfd632f9f6801aaabf79ed5ba6f70e69de0480e15be84f40ebea78433f10aed82e54339231df1063ab2a8b150a0185c1bc9127174347a9d5c71ffe1d
diff --git a/sys-cluster/nomad/nomad-1.5.3.ebuild b/sys-cluster/nomad/nomad-1.5.3.ebuild
new file mode 100644
index 000000000000..1adb04ac4d08
--- /dev/null
+++ b/sys-cluster/nomad/nomad-1.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+GIT_COMMIT=434f7a1745c6304d607562daa9a4a635def7153f
+
+DESCRIPTION="A simple and flexible workload orchestrator"
+HOMEPAGE="https://nomadproject.io"
+SRC_URI="https://github.com/hashicorp/nomad/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="ui"
+
+RESTRICT=" test"
+
+src_compile() {
+ local go_ldflags go_tags
+ go_ldflags="-X github.com/hashicorp/nomad/version.GitCommit=${GIT_COMMIT}"
+ go_tags="codegen_generated"
+ go_tags+="$(usex ui ',ui' '' )"
+ CGO_ENABLED=1 \
+ ego build \
+ -ldflags "${go_ldflags}" \
+ -tags "${go_tags}" \
+ -trimpath \
+ -o bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ systemd_dounit "${FILESDIR}"/nomad.service
+ keepdir /etc/nomad.d
+ einstalldocs
+ dodoc CHANGELOG.md
+ keepdir /var/lib/nomad /var/log/nomad
+ newconfd "${FILESDIR}/nomad.confd" nomad
+ newinitd "${FILESDIR}/nomad.initd" nomad
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/nomad.logrotated" nomad
+}