summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-17 17:42:53 +0100
committerSam James <sam@gentoo.org>2022-04-17 17:42:53 +0100
commitc015ded8c0dea2bea38eec37b5f54855b000f445 (patch)
tree5d0ec3b9ae2524a804b5a87ab5c58f4c77abca70 /sys-boot
parentsys-apps/plocate: drop 1.1.14 (diff)
downloadgentoo-c015ded8c0dea2bea38eec37b5f54855b000f445.tar.gz
gentoo-c015ded8c0dea2bea38eec37b5f54855b000f445.tar.bz2
gentoo-c015ded8c0dea2bea38eec37b5f54855b000f445.zip
sys-boot/raspberrypi-firmware: drop 1.20210527, 1.20211029
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/raspberrypi-firmware/Manifest2
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20210527.ebuild72
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20211029.ebuild72
3 files changed, 0 insertions, 146 deletions
diff --git a/sys-boot/raspberrypi-firmware/Manifest b/sys-boot/raspberrypi-firmware/Manifest
index a0b30a6025ae..db0dff32615b 100644
--- a/sys-boot/raspberrypi-firmware/Manifest
+++ b/sys-boot/raspberrypi-firmware/Manifest
@@ -1,4 +1,2 @@
-DIST raspberrypi-firmware-1.20210527.tar.gz 192247084 BLAKE2B 329707dfb2905b36926a3f0ecf1a8e3bc2b52e1a376f98ca7cfe9ec7b69d0fb370d8e23907f5bbd9ea75cf7fed5babd6fe54934919995dec6914e888d95e5fbe SHA512 5a48d1fae768c30528359a14371f59564447d2fb8a145cafa89d7d29352095c5b7ac33bfcbc8da494284c9d41e7dbafe4e863e8efd963a17ea6b6b9699b814a7
-DIST raspberrypi-firmware-1.20211029.tar.gz 193543221 BLAKE2B 308206d6bdfbe15bfe5f39cd230e6d4857f460744aafcbcc9eee6a74f05a3a9dc861e7c3e36baea46fdb1d1d1dc28b5edebf70bce3a3c085228b2ea321ef7a85 SHA512 7a1fe3b1645006c35fa49e842b9ece53b386ece42b8db99649de8d4bc0c19e34b0807767290e26422528606c5847843533aaa0edd0716e9f9f9dcae340a4dce0
DIST raspberrypi-firmware-1.20211118.tar.gz 193544570 BLAKE2B db6c7c2e247f668b02210fb181305c3244f3d8a30f923656bf15cf418cb26822844df5b39af62b483e9e49405e13a60e57d6826aa0f3c3698920e8fc568656e2 SHA512 54881fc31ca0c9de8d8ca41ad6418e9d149975fbadbc0409f4136d4a31e70d743d55a16d4c0942305077d463c952edaa48be56d22d015983ab672dcaf5f134e2
DIST raspberrypi-firmware-1.20220328.tar.gz 195699471 BLAKE2B e39ae746b46eb4f63aa2043df9fb60ce23b966d172e2c2c311942425e62896fb8ef171689c420bf2545065514a331e46c3bfb4d028eab8eea251357ee4c947f3 SHA512 b9e8676a94dce4621af25b8ba563a2dbd93f6fad61f5c5fb8b57b0ff5262151ff61598ce56a5f952f99f6e37f7c9ebf801a51849ee45ee328a168ca88e2522f3
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20210527.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20210527.ebuild
deleted file mode 100644
index 43c2288dc321..000000000000
--- a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20210527.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit mount-boot readme.gentoo-r1
-
-if [[ "${PV}" == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
- EGIT_CLONE_TYPE="shallow"
-else
- SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="-* arm arm64"
- S="${WORKDIR}/firmware-${PV}"
-fi
-
-DESCRIPTION="Raspberry Pi (all versions) bootloader and GPU firmware"
-HOMEPAGE="https://github.com/raspberrypi/firmware"
-
-LICENSE="GPL-2 raspberrypi-videocore-bin"
-SLOT="0"
-RESTRICT="binchecks strip"
-
-DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"
-
-src_prepare() {
- default
-
- cp "${FILESDIR}"/${PN}-1.20201022-config.txt "${WORKDIR}" || die
-
- if use arm64; then
- # Force selection of the 64-bit kernel8.img to match our userland
- echo "arm_64bit=1" >> "${WORKDIR}"/${PN}-1.20201022-config.txt || die
- fi
-}
-
-src_install() {
- insinto /boot
- cd boot || die
- doins bootcode.bin fixup*.dat start*elf
- newins "${WORKDIR}"/${PN}-1.20201022-config.txt config.txt
- newins "${FILESDIR}"/${PN}-1.20201022-cmdline.txt cmdline.txt
- newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
- readme.gentoo_create_doc
-}
-
-pkg_preinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]] ; then
- local msg=""
-
- if [[ -e "${ED}"/boot/cmdline.txt ]] && [[ -e /boot/cmdline.txt ]] ; then
- msg+="/boot/cmdline.txt "
- fi
-
- if [[ -e "${ED}"/boot/config.txt ]] && [[ -e /boot/config.txt ]] ; then
- msg+="/boot/config.txt "
- fi
-
- if [[ -n "${msg}" ]] ; then
- msg="This package installs following files: ${msg}."
- msg="${msg} Please remove (backup) your copies during install"
- msg="${msg} and merge settings afterwards."
- msg="${msg} Further updates will be CONFIG_PROTECTed."
- die "${msg}"
- fi
- fi
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20211029.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20211029.ebuild
deleted file mode 100644
index 263276be82c7..000000000000
--- a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20211029.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit mount-boot readme.gentoo-r1
-
-if [[ "${PV}" == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
- EGIT_CLONE_TYPE="shallow"
-else
- SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="-* ~arm ~arm64"
- S="${WORKDIR}/firmware-${PV}"
-fi
-
-DESCRIPTION="Raspberry Pi (all versions) bootloader and GPU firmware"
-HOMEPAGE="https://github.com/raspberrypi/firmware"
-
-LICENSE="GPL-2 raspberrypi-videocore-bin"
-SLOT="0"
-RESTRICT="binchecks strip"
-
-DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"
-
-src_prepare() {
- default
-
- cp "${FILESDIR}"/${PN}-1.20201022-config.txt "${WORKDIR}" || die
-
- if use arm64; then
- # Force selection of the 64-bit kernel8.img to match our userland
- echo "arm_64bit=1" >> "${WORKDIR}"/${PN}-1.20201022-config.txt || die
- fi
-}
-
-src_install() {
- insinto /boot
- cd boot || die
- doins bootcode.bin fixup*.dat start*elf
- newins "${WORKDIR}"/${PN}-1.20201022-config.txt config.txt
- newins "${FILESDIR}"/${PN}-1.20201022-cmdline.txt cmdline.txt
- newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
- readme.gentoo_create_doc
-}
-
-pkg_preinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]] ; then
- local msg=""
-
- if [[ -e "${ED}"/boot/cmdline.txt ]] && [[ -e /boot/cmdline.txt ]] ; then
- msg+="/boot/cmdline.txt "
- fi
-
- if [[ -e "${ED}"/boot/config.txt ]] && [[ -e /boot/config.txt ]] ; then
- msg+="/boot/config.txt "
- fi
-
- if [[ -n "${msg}" ]] ; then
- msg="This package installs following files: ${msg}."
- msg="${msg} Please remove (backup) your copies during install"
- msg="${msg} and merge settings afterwards."
- msg="${msg} Further updates will be CONFIG_PROTECTed."
- die "${msg}"
- fi
- fi
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}