summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-boot/winusb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-boot/winusb')
-rw-r--r--sys-boot/winusb/Manifest1
-rw-r--r--sys-boot/winusb/metadata.xml10
-rw-r--r--sys-boot/winusb/winusb-1.0.11.ebuild41
3 files changed, 52 insertions, 0 deletions
diff --git a/sys-boot/winusb/Manifest b/sys-boot/winusb/Manifest
new file mode 100644
index 000000000000..bac25e05f93a
--- /dev/null
+++ b/sys-boot/winusb/Manifest
@@ -0,0 +1 @@
+DIST winusb-1.0.11.tar.gz 566128 SHA256 7bd8d2e63651134bd4173dcf358708fb9e6de1677c088e67d45995a1d5066bc9 SHA512 4d60aa440b811d6fb0a5bb71155f689f767e976572736c324040651b77bfc58d883a98e95afdef63c3cd97b3a49027a059e8e70ebb1d23ba830d7251ac72ae42 WHIRLPOOL 751af916c4eac9b9ca6b60b605466ffd68926a6640a4dbc80013a16122b98b37afb74d1b4ac5832618e060d9d1cd6afbf9724b0aab2a73d9f8b51693956166d4
diff --git a/sys-boot/winusb/metadata.xml b/sys-boot/winusb/metadata.xml
new file mode 100644
index 000000000000..57aaaa1668f3
--- /dev/null
+++ b/sys-boot/winusb/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>yac@gentoo.org</email>
+<name>Jan Matejka</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
diff --git a/sys-boot/winusb/winusb-1.0.11.ebuild b/sys-boot/winusb/winusb-1.0.11.ebuild
new file mode 100644
index 000000000000..6b5318fe7610
--- /dev/null
+++ b/sys-boot/winusb/winusb-1.0.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Creates windows installer on usb media from an iso image"
+HOMEPAGE="http://en.congelli.eu/prog_info_winusb.html"
+SRC_URI="http://en.congelli.eu/directdl/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND="${DEPEND}
+ sys-apps/coreutils
+ sys-apps/grep
+ sys-apps/util-linux
+ sys-block/parted
+ sys-boot/grub:2
+ sys-fs/ntfs3g
+"
+
+src_prepare() {
+ sed -i "s#grub-install#grub2-install#" src/winusb ||
+ die "sed failed"
+}
+
+src_compile() {
+ return; # noop
+}
+
+src_configure() {
+ return; # noop
+}
+
+src_install() {
+ dosbin src/winusb
+}