summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-boot/shlilo-lantank
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-boot/shlilo-lantank')
-rw-r--r--sys-boot/shlilo-lantank/Manifest1
-rw-r--r--sys-boot/shlilo-lantank/files/lilo.conf16
-rw-r--r--sys-boot/shlilo-lantank/metadata.xml5
-rw-r--r--sys-boot/shlilo-lantank/shlilo-lantank-20040408.ebuild33
4 files changed, 55 insertions, 0 deletions
diff --git a/sys-boot/shlilo-lantank/Manifest b/sys-boot/shlilo-lantank/Manifest
new file mode 100644
index 000000000000..d7710f863072
--- /dev/null
+++ b/sys-boot/shlilo-lantank/Manifest
@@ -0,0 +1 @@
+DIST sh-lilo-sel-20040408.tar.gz 85932 SHA256 60b653c63baa160bb4652b56acafd17e462b1bd1dc713620f1e150239ae2877d
diff --git a/sys-boot/shlilo-lantank/files/lilo.conf b/sys-boot/shlilo-lantank/files/lilo.conf
new file mode 100644
index 000000000000..cd5bc81d3835
--- /dev/null
+++ b/sys-boot/shlilo-lantank/files/lilo.conf
@@ -0,0 +1,16 @@
+# Example lilo.conf
+linear
+boot=/dev/hda
+install=/boot/boot.b
+
+# timeout is in 10's of milliseconds; so 100 is 1 second
+prompt
+timeout=800
+default=default
+
+# default kernel settings
+read-only
+append="mem=64M root=/dev/hda1 console=ttySC1,9600"
+
+image=/boot/zImage
+ label=default
diff --git a/sys-boot/shlilo-lantank/metadata.xml b/sys-boot/shlilo-lantank/metadata.xml
new file mode 100644
index 000000000000..b9b9fd717504
--- /dev/null
+++ b/sys-boot/shlilo-lantank/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sh</herd>
+</pkgmetadata>
diff --git a/sys-boot/shlilo-lantank/shlilo-lantank-20040408.ebuild b/sys-boot/shlilo-lantank/shlilo-lantank-20040408.ebuild
new file mode 100644
index 000000000000..116297914a36
--- /dev/null
+++ b/sys-boot/shlilo-lantank/shlilo-lantank-20040408.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit mount-boot
+
+MY_P="sh-lilo-sel-${PV}"
+DESCRIPTION="bootloader for the SuperH Lantank"
+HOMEPAGE="http://www.linux-sh.org/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+ BSD"
+SLOT="0"
+KEYWORDS="-* sh"
+IUSE=""
+RESTRICT="strip"
+
+S=${WORKDIR}/${MY_P}
+
+QA_TEXTRELS_sh="sbin/lilo"
+
+src_compile() { :; }
+
+src_install() {
+ into /
+ dosbin precompiled/lilo || die
+ insinto /boot
+ doins precompiled/boot.b || die
+ dosym . /boot/boot
+ insinto /etc
+ doins "${FILESDIR}"/lilo.conf || die
+ dodoc ChangeLog README TODO
+}