summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-08-28 18:07:24 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-08-28 18:14:00 +0300
commit08a69400ed7aa6f0b3d522f012924f547f31e4bb (patch)
tree1c676e11de698bfe86cfd96d66d8a9f3578eb2eb /sys-boot/refind
parentsys-boot/gnu-efi: fix compilation on different locales (diff)
downloadgentoo-08a69400ed7aa6f0b3d522f012924f547f31e4bb.tar.gz
gentoo-08a69400ed7aa6f0b3d522f012924f547f31e4bb.tar.bz2
gentoo-08a69400ed7aa6f0b3d522f012924f547f31e4bb.zip
sys-boot/refind: fix compilation on different locales
Bug: https://bugs.gentoo.org/938580 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'sys-boot/refind')
-rw-r--r--sys-boot/refind/refind-0.14.2-r2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-boot/refind/refind-0.14.2-r2.ebuild b/sys-boot/refind/refind-0.14.2-r2.ebuild
index 5755a725f1bf..cad032fc658b 100644
--- a/sys-boot/refind/refind-0.14.2-r2.ebuild
+++ b/sys-boot/refind/refind-0.14.2-r2.ebuild
@@ -41,7 +41,7 @@ checktools() {
# llvm-objcopy does not support EFI target, try to use binutils objcopy or fail
tc-export OBJCOPY
OBJCOPY="${OBJCOPY/llvm-/}"
- LANG=C LC_ALL=C "${OBJCOPY}" --help | grep -q '\<pei-' || die "${OBJCOPY} (objcopy) does not support EFI target"
+ LC_ALL=C "${OBJCOPY}" --help | grep -q '\<pei-' || die "${OBJCOPY} (objcopy) does not support EFI target"
tc-is-gcc || tc-is-clang || die "Unsupported compiler"
fi
@@ -106,9 +106,9 @@ src_compile() {
# see the comments in "${FILESDIR}"/${P}-fix-freestanding-on-musl.patch
tc-export CC
if tc-is-gcc; then
- local -x CPPINCLUDEDIR=$(LANG=C ${CC} -print-search-dirs 2> /dev/null | grep ^install: | cut -f2 -d' ')/include
+ local -x CPPINCLUDEDIR=$(LC_ALL=C ${CC} -print-search-dirs 2> /dev/null | grep ^install: | cut -f2 -d' ')/include
elif tc-is-clang; then
- local -x CPPINCLUDEDIR=$(LANG=C ${CC} -print-resource-dir 2> /dev/null)/include
+ local -x CPPINCLUDEDIR=$(LC_ALL=C ${CC} -print-resource-dir 2> /dev/null)/include
local -x EXTRACFLAGS=-D__DEFINED_wchar_t
fi