summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-boot/cromwell
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-boot/cromwell')
-rw-r--r--sys-boot/cromwell/Manifest2
-rw-r--r--sys-boot/cromwell/cromwell-2.40-r3.ebuild38
-rw-r--r--sys-boot/cromwell/files/cromwell-2.40-gcc-4.6.patch39
-rw-r--r--sys-boot/cromwell/metadata.xml6
4 files changed, 85 insertions, 0 deletions
diff --git a/sys-boot/cromwell/Manifest b/sys-boot/cromwell/Manifest
new file mode 100644
index 000000000000..ccdc3f073b89
--- /dev/null
+++ b/sys-boot/cromwell/Manifest
@@ -0,0 +1,2 @@
+DIST cromwell-2.40-r3-cvs-fixes.patch.lzma 7075 RMD160 22e0986c3ee5157f47902095947765be6a1ecfa1 SHA1 1543334d54b31f1667657ed2d7b5107e2ef9d497 SHA256 97d50811000edc399e0323b5faeff169de86846f50439adbc59b6eeaf1bb12fd
+DIST cromwell-2.40.tar.bz2 943015 RMD160 0b1efe4bee94e9d4b130008641fe4d2989439f43 SHA1 ce1b1d5a39f2c319d79ddb162f927ea053e1f354 SHA256 115cf68afad311f6e7490c3091dfb81870416cec3f2cb35d30360a919888cc3c
diff --git a/sys-boot/cromwell/cromwell-2.40-r3.ebuild b/sys-boot/cromwell/cromwell-2.40-r3.ebuild
new file mode 100644
index 000000000000..b7140e1bf5d3
--- /dev/null
+++ b/sys-boot/cromwell/cromwell-2.40-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils mount-boot toolchain-funcs flag-o-matic
+
+DESCRIPTION="Xbox boot loader"
+HOMEPAGE="http://www.xbox-linux.org/wiki/Cromwell"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ mirror://gentoo/${PF}-cvs-fixes.patch.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+RESTRICT="strip"
+
+src_prepare() {
+ epatch "${WORKDIR}"/${PF}-cvs-fixes.patch
+ epatch "${FILESDIR}"/${P}-gcc-4.6.patch #363535
+ sed -i 's:-Werror:-m32:' Makefile Rules.make || die
+ sed -i '/^EXTRA_CFLAGS/s:$: -m32:' Rules.make boot_rom/Makefile || die
+ sed -i \
+ -e '/^bin.imagebld:/,$s:\<gcc\>:${CC}:' \
+ Makefile || die
+ append-flags -m32
+}
+
+src_compile() {
+ emake -j1 CC="$(tc-getCC)" LD="$(tc-getLD)"
+}
+
+src_install() {
+ insinto /boot/${PN}
+ doins image/cromwell{,_1024}.bin xbe/xromwell.xbe
+}
diff --git a/sys-boot/cromwell/files/cromwell-2.40-gcc-4.6.patch b/sys-boot/cromwell/files/cromwell-2.40-gcc-4.6.patch
new file mode 100644
index 000000000000..92de3b014b61
--- /dev/null
+++ b/sys-boot/cromwell/files/cromwell-2.40-gcc-4.6.patch
@@ -0,0 +1,39 @@
+newer gcc versions will output .text.unlikely which this linker script
+doesn't expect
+
+https://bugs.gentoo.org/363535
+
+--- a/scripts/ldscript-crom.ld
++++ b/scripts/ldscript-crom.ld
+@@ -21,7 +21,7 @@ SECTIONS {
+
+ .text LOW_ROM : AT ( 0 ){
+ _start_low_rom = . ;
+- *(.text);
++ *(.text .text.*);
+ _end_low_rom = . ;
+ }
+
+@@ -67,4 +67,5 @@ SECTIONS {
+
+ _end_complete_rom = SIZEOF(.text) + SIZEOF(.rodata) + SIZEOF(.data) + SIZEOF(.bss);
+
++ /DISCARD/ : { *(.eh_frame) }
+ }
+--- a/boot_rom/bootrom.ld
++++ b/boot_rom/bootrom.ld
+@@ -31,7 +31,7 @@ SECTIONS {
+ .text (RAM_CODE) : AT( SIZEOF(.low_rom) ) {
+ _ram_location = .;
+ _start_ramcopy = _end_rom;
+- *(.text);
++ *(.text .text.*);
+ _start_checksum = _start_ramcopy - LOW_ROM;
+ }
+
+@@ -74,4 +74,5 @@ SECTIONS {
+ } = 0x90909090
+ */
+
++ /DISCARD/ : { *(.eh_frame) }
+ }
diff --git a/sys-boot/cromwell/metadata.xml b/sys-boot/cromwell/metadata.xml
new file mode 100644
index 000000000000..f09a62b665f7
--- /dev/null
+++ b/sys-boot/cromwell/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>xbox</herd>
+ <longdescription>Xbox boot loader</longdescription>
+</pkgmetadata>