summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-16 10:25:14 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-08-17 09:48:46 +0200
commit8243b2dc5af55fd82cbbd2898e21d8658974224d (patch)
tree6ea47653a0c91ecef6231f43e838bf0e8078229d /sys-block/sas3ircu
parentsys-block/sas3flash: use secureboot.eclass to sign efi exec (diff)
downloadgentoo-8243b2dc5af55fd82cbbd2898e21d8658974224d.tar.gz
gentoo-8243b2dc5af55fd82cbbd2898e21d8658974224d.tar.bz2
gentoo-8243b2dc5af55fd82cbbd2898e21d8658974224d.zip
sys-block/sas3ircu: use secureboot.eclass to sign efi exec
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-block/sas3ircu')
-rw-r--r--sys-block/sas3ircu/sas3ircu-16.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-block/sas3ircu/sas3ircu-16.ebuild b/sys-block/sas3ircu/sas3ircu-16.ebuild
index b9d4c0a25807..bbd2cebcd65b 100644
--- a/sys-block/sas3ircu/sas3ircu-16.ebuild
+++ b/sys-block/sas3ircu/sas3ircu-16.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit mount-boot
+inherit mount-boot secureboot
DESCRIPTION="LSI MPT-SAS3 controller management tool"
HOMEPAGE="https://www.broadcom.com/products/storage/host-bus-adapters/sas-9300-8e#downloads"
@@ -42,6 +42,10 @@ pkg_nofetch() {
einfo "${SRC_URI}"
}
+pkg_setup() {
+ use efi && secureboot_pkg_setup
+}
+
supportedcards() {
elog "This binary supports should support ALL cards, including, but not"
elog "limited to the following series:"
@@ -84,5 +88,6 @@ src_install() {
elif use arm64; then
doexe sas3ircu_rel/sas3ircu/sas3ircu_udk_uefi_arm_rel/sas3ircu.efi
fi
+ secureboot_auto_sign --in-place
fi
}