summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-03-04 11:33:03 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-03-04 11:54:10 +0100
commitec8ef0d2ca1f65776491d39a3fa7213de18d2709 (patch)
tree3ba3c74b83134e80a8b0b8c4fa56c90737dbb47f /sys-block/open-isns/files
parentnet-misc/ntp: Removed old (diff)
downloadgentoo-ec8ef0d2ca1f65776491d39a3fa7213de18d2709.tar.gz
gentoo-ec8ef0d2ca1f65776491d39a3fa7213de18d2709.tar.bz2
gentoo-ec8ef0d2ca1f65776491d39a3fa7213de18d2709.zip
sys-block/open-isns: Bump to version 0.100
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-block/open-isns/files')
-rw-r--r--sys-block/open-isns/files/open-isns-0.100-no_Werror.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-block/open-isns/files/open-isns-0.100-no_Werror.patch b/sys-block/open-isns/files/open-isns-0.100-no_Werror.patch
new file mode 100644
index 000000000000..2d966dd3a4fd
--- /dev/null
+++ b/sys-block/open-isns/files/open-isns-0.100-no_Werror.patch
@@ -0,0 +1,41 @@
+From 40eb9ce75518817762a0eac4a93016ab817add89 Mon Sep 17 00:00:00 2001
+From: Lee Duncan <lduncan@suse.com>
+Date: Sat, 1 Feb 2020 10:23:04 -0800
+Subject: [PATCH] Fix 586 compile issue and remove -Werror
+
+Using -Werror causes any issue to break the build, whereas
+I'd rather let the build continue and address the issue.
+
+Also, fixed one signed-vs-unsigned compare for time_t, which
+shows up only on 586 (32-bit).
+---
+ configure.ac | 2 +-
+ isnsdd.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index e4f3995..d956e58 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -17,7 +17,7 @@ AC_PATH_PROG(SH, sh)
+ dnl C Compiler features
+ AC_C_INLINE
+ if test "$GCC" = "yes"; then
+- CFLAGS="-Wall -Werror -Wextra $CFLAGS"
++ CFLAGS="-Wall -Wextra $CFLAGS"
+ CPPFLAGS="$CPPFLAGS -D_GNU_SOURCE"
+ fi
+
+diff --git a/isnsdd.c b/isnsdd.c
+index 58825cc..9cedb9f 100644
+--- a/isnsdd.c
++++ b/isnsdd.c
+@@ -401,7 +401,7 @@ check_portal_registration(__attribute__((unused))void *ptr)
+ continue;
+
+ last_modified = isns_object_last_modified(obj);
+- if (last_modified + 2 * interval > now) {
++ if ((time_t)(last_modified + 2 * interval) > now) {
+ good_portals++;
+ continue;
+ }