summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2016-08-12 21:01:51 +0200
committerThomas Deutschmann <whissi@gentoo.org>2016-08-12 21:33:12 +0200
commit0fe2f15bf5b6fd098ae424c9c6153c9d5a67655e (patch)
treebbd9f67864e1fba2793789541c1fb64233d23fe8 /sys-block/hpssacli
parentlicenses: Add Hewlett Packard Enterprise (HPE) End User License Agreement (diff)
downloadgentoo-0fe2f15bf5b6fd098ae424c9c6153c9d5a67655e.tar.gz
gentoo-0fe2f15bf5b6fd098ae424c9c6153c9d5a67655e.tar.bz2
gentoo-0fe2f15bf5b6fd098ae424c9c6153c9d5a67655e.zip
sys-block/hpssacli: New package
The HPE Smart Storage Administrator CLI (HPE SSACLI) is a commandline-based disk configuration program that helps you configure, manage, diagnose, and monitor HPE ProLiant Smart Array Controllers and now other storage devices as well, such as host bus adapters (HBAs), HPE Storage controllers, and future devices such as SCSI Express drives, and SAS switch devices. HPE SSACLI replaces the existing HP Array Configuration CLI Utility, or ACUCLI, with an updated design and will deliver new features and functionality for various Smart Storage initiatives as they come online. Gentoo-Bug: https://bugs.gentoo.org/476640 Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-block/hpssacli')
-rw-r--r--sys-block/hpssacli/Manifest1
-rw-r--r--sys-block/hpssacli/files/hpssacli-wrapper22
-rw-r--r--sys-block/hpssacli/hpssacli-2.40.13.0.ebuild62
-rw-r--r--sys-block/hpssacli/metadata.xml8
4 files changed, 93 insertions, 0 deletions
diff --git a/sys-block/hpssacli/Manifest b/sys-block/hpssacli/Manifest
new file mode 100644
index 000000000000..198ab11b81ef
--- /dev/null
+++ b/sys-block/hpssacli/Manifest
@@ -0,0 +1 @@
+DIST hpssacli-2.40-13.0.x86_64.rpm 11772990 SHA256 1e17602dec56f30dfe9329eb5ea060ac0dbb42ea003a27e8eecaa2148b331599 SHA512 4a650c2700f77bdc79693905e56598cbe8f198d4f54c7c97e05a7b8af830f11c5e5eea2d16538a3c6068eadb75159850b391d7f772f59447bbbd870f64eb7efa WHIRLPOOL b0821a4875724cab30c0e95fccdca71e0700e3008e48fe9efb6d0b5d1f8f3de32259b586aaa5f0bdbd51a350b8467d992ee6aefceac9ee81beb0c34f2a6b0ec7
diff --git a/sys-block/hpssacli/files/hpssacli-wrapper b/sys-block/hpssacli/files/hpssacli-wrapper
new file mode 100644
index 000000000000..2e425f719e20
--- /dev/null
+++ b/sys-block/hpssacli/files/hpssacli-wrapper
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+#
+# Uncomment the line below to turn off discovery of Fibre
+# export INFOMGR_BYPASS_FIBRE=1
+#
+# Uncomment the lines below to turn off discovery of Non-Smart Array controllers
+# export INFOMGR_BYPASS_NONSA=1
+#
+
+cmd="$(basename "$0")"
+
+HPSSACLI_BASEDIR="/opt/hp/hpssacli"
+HPSSACLI_BIN="${HPSSACLI_BASEDIR}/${cmd}.bin"
+
+if pgrep --exact "${cmd}.bin" 1>/dev/null; then
+ echo "Another instance of ${cmd} is running! Stop it first."
+ exit 1
+fi
+
+export LD_LIBRARY_PATH="${HPSSACLI_BASEDIR}"
+"${HPSSACLI_BIN}" "${@}"
diff --git a/sys-block/hpssacli/hpssacli-2.40.13.0.ebuild b/sys-block/hpssacli/hpssacli-2.40.13.0.ebuild
new file mode 100644
index 000000000000..75a43e145983
--- /dev/null
+++ b/sys-block/hpssacli/hpssacli-2.40.13.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit pax-utils rpm versionator
+
+MY_PV=$(replace_version_separator 2 '-')
+
+DESCRIPTION="HPE Smart Storage Administrator (HPE SSA) CLI (HPSSACLI, formerly HPACUCLI)"
+HOMEPAGE="http://h20564.www2.hpe.com/hpsc/swd/public/detail?swItemId=MTX_04bffb688a73438598fef81ddd"
+SRC_URI="http://downloads.linux.hpe.com/SDR/repo/spp/RHEL/7/x86_64/current/${PN}-${MY_PV}.x86_64.rpm"
+
+LICENSE="hpe"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="elibc_glibc? ( >sys-libs/glibc-2.14 )
+ >=sys-libs/libunwind-0.99
+ >=sys-process/procps-3.3.6"
+
+DOCS=( license.txt readme.txt )
+
+MY_HPSSACLI_BASEDIR="/opt/hp/hpssacli"
+
+QA_PREBUILT="${MY_HPSSACLI_BASEDIR:1}/hpssa*.bin"
+QA_EXECSTACK="${MY_HPSSACLI_BASEDIR:1}/hpssa*.bin"
+
+src_unpack() {
+ rpm_src_unpack
+
+ mkdir "${S}" || die "Failed to create '${S}'"
+}
+
+src_prepare() {
+ default
+
+ # Create a clean $S
+ mv "${WORKDIR}"/opt/hp/hpssacli/bld/hpss* "${S}" || die "Failed to to copy 'hpss*' related files"
+ mv "${S}"/hpssacli.license "${S}"/license.txt || die "Renaming hpssacli.license failed!"
+ mv "${S}"/hpssacli*.txt "${S}"/readme.txt || die "Renaming hpssacli*.txt failed!"
+ rm -rf "${WORKDIR}"/opt || die "Failed to cleanup '${WORKDIR}/opt'"
+ rm -rf "${WORKDIR}"/usr || die "Failed to cleanup '${WORKDIR}/usr'"
+}
+
+src_install() {
+ newsbin "${FILESDIR}"/"${PN}-wrapper" ${PN}
+ dosym ${PN} /usr/sbin/hpssascripting
+
+ exeinto "${MY_HPSSACLI_BASEDIR}"
+ for bin in "${S}"/hpssa{cli,scripting}; do
+ local basename=$(basename "${bin}")
+ newexe "${bin}" ${basename}.bin
+ done
+
+ dodoc "${DOCS[@]}"
+
+ pax-mark m "${D%/}${HPSSACLI_BASEDIR}"/*.bin
+}
diff --git a/sys-block/hpssacli/metadata.xml b/sys-block/hpssacli/metadata.xml
new file mode 100644
index 000000000000..a32d600f949d
--- /dev/null
+++ b/sys-block/hpssacli/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+</pkgmetadata>