summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-10-23 12:26:05 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-10-23 12:26:47 -0500
commitb9066feeb2982db24867f93131d6cf6563a29bb6 (patch)
treedac448f273c43c005a1ffc297e06db6750fcfca9 /sys-auth/docker_auth
parentmedia-radio/tlf: Drop -flto and fix some warnings (diff)
downloadgentoo-b9066feeb2982db24867f93131d6cf6563a29bb6.tar.gz
gentoo-b9066feeb2982db24867f93131d6cf6563a29bb6.tar.bz2
gentoo-b9066feeb2982db24867f93131d6cf6563a29bb6.zip
sys-auth/docker_auth: fix "go mod verify" failure
Closes: https://bugs.gentoo.org/877893 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-auth/docker_auth')
-rw-r--r--sys-auth/docker_auth/docker_auth-1.9.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-auth/docker_auth/docker_auth-1.9.0.ebuild b/sys-auth/docker_auth/docker_auth-1.9.0.ebuild
index eaddcf7cccba..29a04edc7e1a 100644
--- a/sys-auth/docker_auth/docker_auth-1.9.0.ebuild
+++ b/sys-auth/docker_auth/docker_auth-1.9.0.ebuild
@@ -21,25 +21,25 @@ DEPEND="${COMMON_DEPEND}"
RDEPEND="${COMMON_DEPEND}"
RESTRICT=" test"
+S="${S}/auth_server"
src_compile() {
- pushd auth_server || die
# see the upstream Makefile for how to generate the VERSION and
# BUILD_ID values.
emake \
VERSION=2022022022 \
BUILD_ID=20220220-221158/1.9.0@636c09af \
build
- popd || die
}
src_install() {
+ cd ..
+ dobin auth_server/auth_server
dodoc README.md docs/*
insinto /usr/share/${PF}
doins -r examples
insinto /etc/docker_auth/
newins examples/reference.yml config.yml.example
- dobin auth_server/auth_server
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
insinto /etc/logrotate.d