summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-02-23 15:20:15 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-02-24 17:08:59 +0200
commite898150c02d15694d3428ddf40a197ebf94d41ba (patch)
tree6d0647491bb79424b98e6ff0f4b0686e6604b8f5 /sys-apps
parentsys-apps/s6-linux-utils: add 2.6.1.1 (diff)
downloadgentoo-e898150c02d15694d3428ddf40a197ebf94d41ba.tar.gz
gentoo-e898150c02d15694d3428ddf40a197ebf94d41ba.tar.bz2
gentoo-e898150c02d15694d3428ddf40a197ebf94d41ba.zip
sys-apps/s6-portable-utils: add 2.3.0.1
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/29748 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/s6-portable-utils/Manifest1
-rw-r--r--sys-apps/s6-portable-utils/s6-portable-utils-2.3.0.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sys-apps/s6-portable-utils/Manifest b/sys-apps/s6-portable-utils/Manifest
index 85ae0c96d7d9..f3178397269d 100644
--- a/sys-apps/s6-portable-utils/Manifest
+++ b/sys-apps/s6-portable-utils/Manifest
@@ -1,3 +1,4 @@
DIST s6-portable-utils-2.2.5.0.tar.gz 50911 BLAKE2B e79d803544e8df6b791ecd22bd61b7c9535945c5557a25d7bc5488f5015967c4a750f1c0a136cc49b30ddd5bf3fbc17927e5ec01184106e44d0c08643e98e41a SHA512 2e90a1390140818268bd83629579098552c22160537874a90d4be94fae157cb9cdb864859c40847e8588fa9f62fb5af7bf89aa12561f1e6678a7cffc0f0a6d68
DIST s6-portable-utils-2.2.5.1.tar.gz 51814 BLAKE2B ce4f38d7fb7c632f0e8c10c2990d10eb4f5af38330f29aa3b6e6b97fcce5687eb06a7ee241be5f92f093d5edf5a523da993f140c697ec0dbcef46aacb7f88f87 SHA512 814ab6467034657d3b46e5b933786a2eab1f9cb630c6d67c91ee635facac7d82b5871b94e53445d57fd466c98cc21ea2df4b74c8d48acc0f0c96e14fb827f613
DIST s6-portable-utils-2.3.0.0.tar.gz 51712 BLAKE2B a0a26d2b287629789861df1380ff2903a356a0f461356746c7793b1b99daf5158202b95ee2bdded9a290d3bed8a94286252301329a1d491f47dde44000ab9390 SHA512 1ef0b937e2f698fb1b98440a84be0310e9be44763969ca812744ebc0a91fe75c50d5082067b6bb07c1acd9df1540f71b6d20254b97e4851bb28937815073298c
+DIST s6-portable-utils-2.3.0.1.tar.gz 51746 BLAKE2B 50190c7c55a4e5d79a55a7a9edfa948931ecce3f6e33d2f95113a8e8ea3a5587dfcf7a98b54236eb66488976044d0b319ce0a45c0eb3a1b7399be299bab711fc SHA512 46f4a09d124e44b9b2ac3b8fa8f7b4492207f0a03a052e7b15309aeea175682f7366ff74fbd8a2732952c8f3bbb2fcc69b4bca89609b690e91d167bd25c16b90
diff --git a/sys-apps/s6-portable-utils/s6-portable-utils-2.3.0.1.ebuild b/sys-apps/s6-portable-utils/s6-portable-utils-2.3.0.1.ebuild
new file mode 100644
index 000000000000..84d119227fea
--- /dev/null
+++ b/sys-apps/s6-portable-utils/s6-portable-utils-2.3.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Set of tiny portable unix utilities"
+HOMEPAGE="https://www.skarnet.org/software/s6-portable-utils/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND=">=dev-libs/skalibs-2.13.0.0:="
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir="/$(get_libdir)"
+ --libdir="/usr/$(get_libdir)/${PN}"
+ --with-dynlib="/$(get_libdir)"
+ --with-lib="/usr/$(get_libdir)/skalibs"
+ --with-sysdeps="/usr/$(get_libdir)/skalibs"
+ --disable-allstatic
+ --disable-static
+ --disable-static-libc
+ )
+
+ econf "${myconf[@]}"
+}