summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-18 15:40:23 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-19 15:44:12 +0100
commit717506d584ca9e89a09f72751a624300ebf9d28e (patch)
tree827fd4be601862f222469f7d7c192790c7e41f05 /sys-apps
parentMove {dev-util → dev-debug}/ltrace (diff)
downloadgentoo-717506d584ca9e89a09f72751a624300ebf9d28e.tar.gz
gentoo-717506d584ca9e89a09f72751a624300ebf9d28e.tar.bz2
gentoo-717506d584ca9e89a09f72751a624300ebf9d28e.zip
Move {dev-util → dev-debug}/strace
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/coreutils-8.32-r1.ebuild6
-rw-r--r--sys-apps/coreutils/coreutils-9.1-r2.ebuild6
-rw-r--r--sys-apps/coreutils/coreutils-9.3-r2.ebuild6
-rw-r--r--sys-apps/coreutils/coreutils-9.3-r3.ebuild6
-rw-r--r--sys-apps/coreutils/coreutils-9.4.ebuild2
-rw-r--r--sys-apps/coreutils/coreutils-9999.ebuild4
6 files changed, 15 insertions, 15 deletions
diff --git a/sys-apps/coreutils/coreutils-8.32-r1.ebuild b/sys-apps/coreutils/coreutils-8.32-r1.ebuild
index 3dc5686f020d..01a7a97fc192 100644
--- a/sys-apps/coreutils/coreutils-8.32-r1.ebuild
+++ b/sys-apps/coreutils/coreutils-8.32-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_10 )
inherit flag-o-matic python-any-r1 toolchain-funcs
@@ -38,9 +38,9 @@ BDEPEND="
app-arch/xz-utils
dev-lang/perl
test? (
+ dev-debug/strace
dev-lang/perl
dev-perl/Expect
- dev-util/strace
${PYTHON_DEPS}
)
"
diff --git a/sys-apps/coreutils/coreutils-9.1-r2.ebuild b/sys-apps/coreutils/coreutils-9.1-r2.ebuild
index 5fb7309f58a2..61d1ba7df222 100644
--- a/sys-apps/coreutils/coreutils-9.1-r2.ebuild
+++ b/sys-apps/coreutils/coreutils-9.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,7 +7,7 @@ EAPI=7
# The upstream coreutils maintainers also maintain the package in Fedora and may
# backport fixes which we want to pick up.
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/coreutils.asc
inherit flag-o-matic python-any-r1 toolchain-funcs verify-sig
@@ -52,9 +52,9 @@ BDEPEND="
app-arch/xz-utils
dev-lang/perl
test? (
+ dev-debug/strace
dev-lang/perl
dev-perl/Expect
- dev-util/strace
${PYTHON_DEPS}
)
verify-sig? ( sec-keys/openpgp-keys-coreutils )
diff --git a/sys-apps/coreutils/coreutils-9.3-r2.ebuild b/sys-apps/coreutils/coreutils-9.3-r2.ebuild
index 42a48c3d0a52..be73ff76f43b 100644
--- a/sys-apps/coreutils/coreutils-9.3-r2.ebuild
+++ b/sys-apps/coreutils/coreutils-9.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,7 +9,7 @@ EAPI=8
#
# Also recommend subscribing to the coreutils and bug-coreutils MLs.
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/coreutils.asc
inherit flag-o-matic python-any-r1 toolchain-funcs verify-sig
@@ -63,9 +63,9 @@ BDEPEND="
app-arch/xz-utils
dev-lang/perl
test? (
+ dev-debug/strace
dev-lang/perl
dev-perl/Expect
- dev-util/strace
${PYTHON_DEPS}
)
verify-sig? ( sec-keys/openpgp-keys-coreutils )
diff --git a/sys-apps/coreutils/coreutils-9.3-r3.ebuild b/sys-apps/coreutils/coreutils-9.3-r3.ebuild
index bb5183a62b15..4f124cf83228 100644
--- a/sys-apps/coreutils/coreutils-9.3-r3.ebuild
+++ b/sys-apps/coreutils/coreutils-9.3-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,7 +9,7 @@ EAPI=8
#
# Also recommend subscribing to the coreutils and bug-coreutils MLs.
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/coreutils.asc
inherit flag-o-matic python-any-r1 toolchain-funcs verify-sig
@@ -63,9 +63,9 @@ BDEPEND="
app-arch/xz-utils
dev-lang/perl
test? (
+ dev-debug/strace
dev-lang/perl
dev-perl/Expect
- dev-util/strace
${PYTHON_DEPS}
)
verify-sig? ( sec-keys/openpgp-keys-coreutils )
diff --git a/sys-apps/coreutils/coreutils-9.4.ebuild b/sys-apps/coreutils/coreutils-9.4.ebuild
index f28b7d85381c..40a2c20ada63 100644
--- a/sys-apps/coreutils/coreutils-9.4.ebuild
+++ b/sys-apps/coreutils/coreutils-9.4.ebuild
@@ -63,9 +63,9 @@ BDEPEND="
app-arch/xz-utils
dev-lang/perl
test? (
+ dev-debug/strace
dev-lang/perl
dev-perl/Expect
- dev-util/strace
${PYTHON_DEPS}
)
verify-sig? ( sec-keys/openpgp-keys-coreutils )
diff --git a/sys-apps/coreutils/coreutils-9999.ebuild b/sys-apps/coreutils/coreutils-9999.ebuild
index 3ad9fc001a09..14e289049915 100644
--- a/sys-apps/coreutils/coreutils-9999.ebuild
+++ b/sys-apps/coreutils/coreutils-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -63,9 +63,9 @@ BDEPEND="
app-arch/xz-utils
dev-lang/perl
test? (
+ dev-debug/strace
dev-lang/perl
dev-perl/Expect
- dev-util/strace
${PYTHON_DEPS}
)
verify-sig? ( sec-keys/openpgp-keys-coreutils )