summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-10-02 01:34:16 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-10-02 01:34:16 +0200
commit6178165e223acdba9352c6b7ce2cc727561dfb20 (patch)
tree82ee19f41e40b6f12eb7319ee44bc1f03e5bbd87 /sys-apps
parentgames-fps/eduke32: drop 20220702.10113-r1 (diff)
downloadgentoo-6178165e223acdba9352c6b7ce2cc727561dfb20.tar.gz
gentoo-6178165e223acdba9352c6b7ce2cc727561dfb20.tar.bz2
gentoo-6178165e223acdba9352c6b7ce2cc727561dfb20.zip
sys-apps/hw-probe: add 1.6.5
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hw-probe/Manifest1
-rw-r--r--sys-apps/hw-probe/hw-probe-1.6.5.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/sys-apps/hw-probe/Manifest b/sys-apps/hw-probe/Manifest
index cf47cb22e1d0..236f7de72729 100644
--- a/sys-apps/hw-probe/Manifest
+++ b/sys-apps/hw-probe/Manifest
@@ -1 +1,2 @@
DIST hw-probe-1.6.4.tar.gz 162317 BLAKE2B 5fc5ddf032c6b2504430349089d95be5310a7ac7752a2b6c3c504240dae6572ee773f8360d6449e9122b20de904a7348a2bdc0af660de44f14cf37b16664ef2a SHA512 c812ebdb23f6b8a4df2f2849a29ecc1307c09f758aeb912face6e899510af69f9dee606fb0ff1807a6de1e89a5f7a8b3259b894cc823b9d25efbf26accf60ac4
+DIST hw-probe-1.6.5.tar.gz 163190 BLAKE2B 1d2ceb152d387018f427cd623897f8c4cc8828a6952c54bb9caa673797ac347b64d9daffcddeca16e8274e5ad42c2cff22efe3330209da1eee5476636167f0ad SHA512 68d6709ca4efe82e0e5de3b580c68f76fa31384af0c53645b6609cee14b944a410e58b12ac13f879d8d86220c1088cfaad17dc6edd24cf27700e449add6f6488
diff --git a/sys-apps/hw-probe/hw-probe-1.6.5.ebuild b/sys-apps/hw-probe/hw-probe-1.6.5.ebuild
new file mode 100644
index 000000000000..89965032f4b0
--- /dev/null
+++ b/sys-apps/hw-probe/hw-probe-1.6.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature readme.gentoo-r1
+
+DESCRIPTION="A tool to probe for hardware, check it's operability and find drivers"
+HOMEPAGE="https://github.com/linuxhw/hw-probe/"
+SRC_URI="https://github.com/linuxhw/hw-probe/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Digest-SHA1
+ net-misc/curl
+ sys-apps/dmidecode
+ sys-apps/edid-decode
+ sys-apps/hwinfo
+ sys-apps/pciutils
+ sys-apps/smartmontools
+ sys-apps/usbutils
+ virtual/perl-Data-Dumper
+"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "showing Machine Check Exceptions." app-admin/mcelog
+ optfeature "showing additional I/O statistics." app-admin/sysstat
+ optfeature "showing display data channel (ddc) information." app-misc/ddcutil
+ optfeature "showing smart card (reader) information." dev-libs/opensc
+ optfeature "showing Vulkan GPU hardware information." dev-util/vulkan-tools
+ optfeature "showing information of attached scanners." media-gfx/sane-backends
+ optfeature "showing GPU information provided by MESA." media-libs/mesa
+ optfeature "showing zeroconf statistics." net-dns/avahi
+ optfeature "showing HP printer statistics." net-print/hplip
+ optfeature "showing status about rfkill switches on communication devices." net-wireless/rfkill
+ optfeature "showing additional CPU capabilities." sys-apps/cpuid
+ optfeature "showing hard disk (HDD, SSD, ..) capabilities." sys-apps/hdparm
+ optfeature "showing available I2C sensors." sys-apps/i2c-tools
+ optfeature "showing additional hardware and system information detected by inxi." sys-apps/inxi
+ optfeature "showing information about tested memory for faults." sys-apps/memtester
+ optfeature "showing 'Plug & Play' devices." sys-apps/pnputils
+ optfeature "showing systemd boot process information." sys-apps/systemd
+ optfeature "showing ACPI statistics and tables." sys-power/iasl
+ optfeature "showing information about NUMA." sys-process/numactl
+ optfeature "showing additional GPU information provided by MESA progs." x11-apps/mesa-progs
+ optfeature "showing available Xinput devices." x11-apps/xinput
+}